summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/bones
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/bones')
-rw-r--r--dev-ruby/bones/Manifest2
-rw-r--r--dev-ruby/bones/bones-3.8.1-r1.ebuild38
-rw-r--r--dev-ruby/bones/bones-3.8.3.ebuild35
-rw-r--r--dev-ruby/bones/files/bones-3.8.1-builder.patch15
-rw-r--r--dev-ruby/bones/files/bones-3.8.1-rdoc-version.patch11
-rw-r--r--dev-ruby/bones/metadata.xml8
6 files changed, 109 insertions, 0 deletions
diff --git a/dev-ruby/bones/Manifest b/dev-ruby/bones/Manifest
new file mode 100644
index 000000000000..a9f954dceaab
--- /dev/null
+++ b/dev-ruby/bones/Manifest
@@ -0,0 +1,2 @@
+DIST bones-3.8.1.gem 39936 SHA256 7fd2ec25c6780df4b51db24b85b60a42f9b2a7205dbc90fad992aa639166453c SHA512 d9f3abbb31c4c7856aefb62d2850752bf2d1e8a353f4cf065fd6292d7ae30c3916348fd84e720e6ef43aa4ed1461dc225b08f9dd83371122a61c6461c41a7e4a WHIRLPOOL ba8fcb3b4678137e29c9b63d93134869d5b7f7a2169bc2f8e5c959d9201b01ef67be64ad5964ddba47fe8313867800d08398b62a2173a5e9041bb41728e654cf
+DIST bones-3.8.3.gem 39936 SHA256 862b07d5cc84545dad43c848cc8d78ec001a6b430f7cce5c4a03efadb956c8e6 SHA512 1047a48647855e51db9c95ffab13b19424b22e2583cc8083e60ac160e932f3bf9672fc99e30bf49ca08d3a31aefea2c697e8a9ef918787eb5731122927fb859f WHIRLPOOL d2764990d09c501bbc35b164f5bffc2777958f5642b9779312682efe531feb8fea05fa503b612d4684f50440726449b028190fcd5b6ebc6ddeefbd227edc4016
diff --git a/dev-ruby/bones/bones-3.8.1-r1.ebuild b/dev-ruby/bones/bones-3.8.1-r1.ebuild
new file mode 100644
index 000000000000..604fe99e05e1
--- /dev/null
+++ b/dev-ruby/bones/bones-3.8.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="default version.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tool that creates new Ruby projects from a code skeleton"
+HOMEPAGE="http://github.com/TwP/bones"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/builder
+ >=dev-ruby/loquacious-1.9.1
+ >=dev-ruby/little-plugger-1.1.3
+ >=dev-ruby/rake-0.8.7"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-builder.patch
+ mv ../metadata .
+ epatch "${FILESDIR}"/${P}-rdoc-version.patch
+ mv metadata ../
+}
diff --git a/dev-ruby/bones/bones-3.8.3.ebuild b/dev-ruby/bones/bones-3.8.3.ebuild
new file mode 100644
index 000000000000..a3c7a3b6042e
--- /dev/null
+++ b/dev-ruby/bones/bones-3.8.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="default version.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tool that creates new Ruby projects from a code skeleton"
+HOMEPAGE="http://github.com/TwP/bones"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/builder
+ >=dev-ruby/loquacious-1.9.1
+ >=dev-ruby/little-plugger-1.1.3
+ >=dev-ruby/rake-10"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.8.1-builder.patch
+}
diff --git a/dev-ruby/bones/files/bones-3.8.1-builder.patch b/dev-ruby/bones/files/bones-3.8.1-builder.patch
new file mode 100644
index 000000000000..b676c33a039f
--- /dev/null
+++ b/dev-ruby/bones/files/bones-3.8.1-builder.patch
@@ -0,0 +1,15 @@
+--- a/lib/bones/gem_package_task.rb 2013-12-03 19:04:22.577553656 +0000
++++ b/lib/bones/gem_package_task.rb 2013-12-03 19:04:36.576377667 +0000
+@@ -2,11 +2,7 @@
+ require 'find'
+ require 'rake/packagetask'
+ require 'rubygems/user_interaction'
+-if RUBY_VERSION >= "2"
+- require 'rubygems/package'
+-else
+- require 'rubygems/builder'
+-end
++require 'builder'
+
+ class Bones::GemPackageTask < Rake::PackageTask
+
diff --git a/dev-ruby/bones/files/bones-3.8.1-rdoc-version.patch b/dev-ruby/bones/files/bones-3.8.1-rdoc-version.patch
new file mode 100644
index 000000000000..afff683450b0
--- /dev/null
+++ b/dev-ruby/bones/files/bones-3.8.1-rdoc-version.patch
@@ -0,0 +1,11 @@
+--- a/bones/metadata 2013-12-04 19:12:17.677881011 +0000
++++ b/bones/metadata 2013-12-04 19:14:36.905130687 +0000
+@@ -28,7 +28,7 @@
+ name: rdoc
+ requirement: !ruby/object:Gem::Requirement
+ requirements:
+- - - ~>
++ - - '>='
+ - !ruby/object:Gem::Version
+ version: '3.0'
+ type: :runtime
diff --git a/dev-ruby/bones/metadata.xml b/dev-ruby/bones/metadata.xml
new file mode 100644
index 000000000000..14004b7f8d5a
--- /dev/null
+++ b/dev-ruby/bones/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">TwP/bones</remote-id>
+ </upstream>
+</pkgmetadata>