summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-01 07:14:25 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-01 07:15:25 +0200
commit0b2a7415fd6e21cb3747b746412d59229d0ec5e7 (patch)
tree19db449be107c2539c1921e43548a065a9f98918 /dev-ruby/hamster/hamster-3.0.0-r1.ebuild
parentprofiles: use.stable.mask pypy and pypy3 python targets (diff)
downloadgentoo-0b2a7415fd6e21cb3747b746412d59229d0ec5e7.tar.gz
gentoo-0b2a7415fd6e21cb3747b746412d59229d0ec5e7.tar.bz2
gentoo-0b2a7415fd6e21cb3747b746412d59229d0ec5e7.zip
dev-ruby/hamster: add missing dependency, fixes bug 592602
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/hamster/hamster-3.0.0-r1.ebuild')
-rw-r--r--dev-ruby/hamster/hamster-3.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/hamster/hamster-3.0.0-r1.ebuild b/dev-ruby/hamster/hamster-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..f858af7d6bfd
--- /dev/null
+++ b/dev-ruby/hamster/hamster-3.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Efficient, immutable, thread-safe collection classes for Ruby"
+HOMEPAGE="https://github.com/hamstergem/hamster"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/concurrent-ruby:1"
+
+all_ruby_prepare() {
+ sed -i -e '/codeclimate/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb spec/lib/hamster/vector/insert_spec.rb || die
+}