summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-01 07:27:40 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-01 07:27:40 +0100
commit9513576ea313ba241e6aac100ac6f307a681ece3 (patch)
tree78e659fab368a853b0e366619b1796eb3be99df3 /dev-ruby/introspection
parentdev-ruby/instantiator: add 0.0.7 (diff)
downloadgentoo-9513576ea313ba241e6aac100ac6f307a681ece3.tar.gz
gentoo-9513576ea313ba241e6aac100ac6f307a681ece3.tar.bz2
gentoo-9513576ea313ba241e6aac100ac6f307a681ece3.zip
dev-ruby/introspection: add 0.0.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/introspection')
-rw-r--r--dev-ruby/introspection/Manifest1
-rw-r--r--dev-ruby/introspection/introspection-0.0.4.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/introspection/Manifest b/dev-ruby/introspection/Manifest
index 09c6442963f4..6c1081d94cdb 100644
--- a/dev-ruby/introspection/Manifest
+++ b/dev-ruby/introspection/Manifest
@@ -1 +1,2 @@
DIST introspection-0.0.3.gem 9216 SHA256 3933d9573f20e00cf26a03bb7c3f765ed136da5ca01dc9c5987875877538323c SHA512 423722f402a8a5cb5f415c498cf754a2b5084b0a89ada48b982a97e3951d9af4bcd675d5dc4a2eacdd0673bf08facaba845e767e3e248e0a8ec922eddbc53c37 WHIRLPOOL 1402be6c805c09850c4705970c91aed6e7763f26483f0e131c12d5feee3bf5985de23612e39c055b9a84f70fd513d78c8be31d1cc719591160f2626699a05581
+DIST introspection-0.0.4.gem 9216 SHA256 8abd4f906cc644aa39bf879f28ec9a0267452342c5689d6c75f40336655c56f8 SHA512 c228827ac9d8a82a104e78daadf038c674cd464bf726fc3bd1efa82e9d9cab37f6ee909f578585e7846378f0b755ed4d60fa119fd699f6c40188ea2de4ac7084 WHIRLPOOL b5d8df9c9b0db1eba7524185fd3cc12715ba1ad5a8997c38a9f6789ff5f594b9f775409dd1ead5f1f0ce43614966d13ef909f7c956526ec7e5a9c787b864a882
diff --git a/dev-ruby/introspection/introspection-0.0.4.ebuild b/dev-ruby/introspection/introspection-0.0.4.ebuild
new file mode 100644
index 000000000000..33dbf229f0d5
--- /dev/null
+++ b/dev-ruby/introspection/introspection-0.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Dynamic inspection of the hierarchy of method definitions on a Ruby object"
+HOMEPAGE="http://jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metaclass-0.0.1"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}