summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-12 08:34:15 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-12 09:21:25 +0200
commit977f41fffb5ae3a6e1ec00058ffbe637e95093a4 (patch)
tree7d210bd8238dbf704a257000e28f1c28da7850bf /dev-ruby/nokogiri
parentapp-emacs/wanderlust: drop 2.15.9_p20190623 (diff)
downloadgentoo-977f41fffb5ae3a6e1ec00058ffbe637e95093a4.tar.gz
gentoo-977f41fffb5ae3a6e1ec00058ffbe637e95093a4.tar.bz2
gentoo-977f41fffb5ae3a6e1ec00058ffbe637e95093a4.zip
dev-ruby/nokogiri: add 1.15.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/Manifest1
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.15.4.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-ruby/nokogiri/Manifest b/dev-ruby/nokogiri/Manifest
index 577cc1fe86ed..4bc8fa4d6870 100644
--- a/dev-ruby/nokogiri/Manifest
+++ b/dev-ruby/nokogiri/Manifest
@@ -4,3 +4,4 @@ DIST nokogiri-1.14.4-git.tgz 10767764 BLAKE2B b0983b5537ea6ffc86431740e2277bb58a
DIST nokogiri-1.15.1-git.tgz 10766136 BLAKE2B 60e86e819aceada10cee805928d1e451ec052ebc16c1577aa22198c1dfdab2ece0462ada4ecb80b77f838df8ce7be8c5a6006ad1039341303d9d1574c825ebf5 SHA512 1e57aba16507ae6b760cbf94ca2260f826479d37eac34ddc0e9a0ff2cd3520014b402d2d571516b8ccf486b085e7ee27779cee992c04fe8f20f7f435121d3bbf
DIST nokogiri-1.15.2-git.tgz 10766215 BLAKE2B 76ac705456790187a9487e8e786bcb2f9e34df3b26b8c2d9942545fba89735dd9493494e1c681b8721fbeab4087a24ff240619654a655d2eb6fe328ba42d7d98 SHA512 12faecdea2f4c06e270de09412f116f0a9ec494a266b0f38938ab3866164485c425189e93cad1d9b682aec2d65c6ec6c3dc76f32e2221510d8e1c1b2890152e9
DIST nokogiri-1.15.3-git.tgz 10767496 BLAKE2B d9d2abd3f57fd3f9e3e49e38de7559d5d9bad278166b4108d2edf4f90884256c01bf574cec8a15b6f30420c9f4d501707b710e3af0f32dc5cbcc01b4433c6662 SHA512 9084e97c81bca52c19cf2cd47dcf0d3377705ceda559399aa1cbf1e112845b2a796e34576f08a073377fb523a7a298254bda91563929535734700c31c473cb49
+DIST nokogiri-1.15.4-git.tgz 10767816 BLAKE2B fe35809f62279ded261c655cc589fdb3447514f6525b62d591da58f91cc9dced34f5ac3e8bde180944ce23a67f56b2f93c90ac9cf69699e331dceee1ea259408 SHA512 f255a51053c55151c6df8937a979833571e2cbc8a25d032674d71d1303267ed4d3a1226d0995e54d9a152f237b31e7fe85e70fb976578902234eb5a2f4f3ce2b
diff --git a/dev-ruby/nokogiri/nokogiri-1.15.4.ebuild b/dev-ruby/nokogiri/nokogiri-1.15.4.ebuild
new file mode 100644
index 000000000000..880304279034
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.15.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md ROADMAP.md SECURITY.md"
+
+RUBY_FAKEGEM_GEMSPEC="nokogiri.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/nokogiri/extconf.rb)
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser"
+HOMEPAGE="https://nokogiri.org/"
+LICENSE="MIT"
+SRC_URI="https://github.com/sparklemotion/nokogiri/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ >=dev-libs/libxml2-2.11.5
+ >=dev-libs/libxslt-1.1.37
+ sys-libs/zlib
+ virtual/libiconv"
+DEPEND="${DEPEND}
+ >=dev-libs/libxml2-2.11.5
+ >=dev-libs/libxslt-1.1.38
+ >=sys-libs/zlib-1.2.13
+ virtual/libiconv"
+
+ruby_add_rdepend ">=dev-ruby/racc-1.4:0"
+
+ruby_add_bdepend "
+ dev-ruby/mini_portile2:2.8
+ >=dev-ruby/rexical-1.0.7
+ dev-ruby/rdoc
+ test? ( dev-ruby/minitest dev-ruby/rubyzip )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ -e '/license/ s:^:#:' \
+ Rakefile || die
+ # Remove the cross compilation options since they interfere with
+ # native building.
+ sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
+ sed -i -e '/cross_config_options/d' Rakefile || die
+
+ sed -e '/simplecov/,/^end/ s:^:#:' \
+ -e '/reporters/I s:^:#:' \
+ -i test/helper.rb || die
+
+ # There is no need for mini_portile2 to be a runtime dependency on Gentoo
+ sed -i -e '/mini_portile2/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ NOKOGIRI_USE_SYSTEM_LIBRARIES=true \
+ ${RUBY} -Cext/${PN} extconf.rb \
+ --with-zlib-include="${EPREFIX}"/usr/include \
+ --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
+ --with-iconv-include="${EPREFIX}"/usr/include \
+ --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
+ --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
+ --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
+ --with-xslt-dir="${EPREFIX}"/usr \
+ --with-iconvlib=iconv \
+ || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
+ fi
+
+ if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
+ fi
+
+ emake -Cext/${PN} \
+ V=1 \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=1 ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each {|f| require f}' || die
+}