summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/protected_attributes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/protected_attributes')
-rw-r--r--dev-ruby/protected_attributes/Manifest3
-rw-r--r--dev-ruby/protected_attributes/metadata.xml8
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.0.9.ebuild40
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild40
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.1.3.ebuild40
5 files changed, 131 insertions, 0 deletions
diff --git a/dev-ruby/protected_attributes/Manifest b/dev-ruby/protected_attributes/Manifest
new file mode 100644
index 000000000000..89d9a28cd59c
--- /dev/null
+++ b/dev-ruby/protected_attributes/Manifest
@@ -0,0 +1,3 @@
+DIST protected_attributes-1.0.9.tar.gz 22212 SHA256 e22ce3bbf9a6edea7c468518fb86aafefb4137f937f62552fe2d56c89fc2e19e SHA512 ed630460df14ea290d9146448908067e0f418568fa31f1f7dbc014954738ca8ee0ff70992c8d77eab9af446a2e1a91e24acb7585d9030a4ab6cae6ede8ee8a4a WHIRLPOOL 7af9a3c1c2c93c0b17443b7fbcbedbd1baa7c54c7541a692353195d3ea457ac530f31f2446835918c2ee0512aa585b3d574a913a9eebd1a39f24c5a988ac3d8c
+DIST protected_attributes-1.1.1.tar.gz 23227 SHA256 bb946ebc575a8f9286ba689b641f6f397a79ea308c8008a1a30ee50c6c3b7bbc SHA512 94b21cfc5bbb16ad704e627a89d091d81e5a4c468052de3e6ad80292dab057408b4e6b230e68ef2382a089985faef790568851747e684710ecc5ad4ff6c3f0d3 WHIRLPOOL c5571d93a27301854bf27505ff98dc146a4f91fbb64f5d5ca36588239b535d6ca47f3971242ae2444e496151abd13239560cec2e17296c757549c826d911ba06
+DIST protected_attributes-1.1.3.tar.gz 23148 SHA256 0dba89d47e96762b6e2c9cedc1d96a06a16bb307136e23cfc89830602bc97a4b SHA512 e20acd5c392eedc62af18745518249273351104dd0a05e33e459d2ac36706a7c6fdc151d4043370a4527d3e8e96417b26bad2e0f3b21cef3a512bd169d635d45 WHIRLPOOL 311cd7fd9634794d72fae25a903767cbf3894ea07814e8654739e30b3354a49cbe1417dd89462f94f7ed290e7d182132f57aa21106a1e9282be55f5c72508164
diff --git a/dev-ruby/protected_attributes/metadata.xml b/dev-ruby/protected_attributes/metadata.xml
new file mode 100644
index 000000000000..a49623c4ff72
--- /dev/null
+++ b/dev-ruby/protected_attributes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/protected_attributes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.0.9.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.0.9.ebuild
new file mode 100644
index 000000000000..e217a9ffa03a
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4* >=dev-ruby/activemodel-4.0.1
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ =dev-ruby/rails-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild
new file mode 100644
index 000000000000..aeb4f5d78f03
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*:* >=dev-ruby/activemodel-4.0.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ =dev-ruby/rails-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.1.3.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.1.3.ebuild
new file mode 100644
index 000000000000..aeb4f5d78f03
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*:* >=dev-ruby/activemodel-4.0.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ =dev-ruby/rails-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}