summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-09 11:44:11 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-09 11:44:38 +0100
commit959cc930bcf64cbc03256f437685f4f79d18fd91 (patch)
tree3c38ffe867af2519e1e05cef1dd9c4dabd4d654d /dev-ruby/puppet_forge
parentdev-ruby/gettext-setup: add ruby26 (diff)
downloadgentoo-959cc930bcf64cbc03256f437685f4f79d18fd91.tar.gz
gentoo-959cc930bcf64cbc03256f437685f4f79d18fd91.tar.bz2
gentoo-959cc930bcf64cbc03256f437685f4f79d18fd91.zip
dev-ruby/puppet_forge: initial import of 2.2.9
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/puppet_forge')
-rw-r--r--dev-ruby/puppet_forge/Manifest1
-rw-r--r--dev-ruby/puppet_forge/metadata.xml16
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/Manifest b/dev-ruby/puppet_forge/Manifest
new file mode 100644
index 000000000000..583e1a86edca
--- /dev/null
+++ b/dev-ruby/puppet_forge/Manifest
@@ -0,0 +1 @@
+DIST puppet_forge-2.2.9.gem 772608 BLAKE2B 15cad2cc183688262b96a35af46324a3264b8a615fa414bddb6b55587ac30f4fdcc64ddaa0f18b66571bde1a1eb17339bf1fad1630f3a06b6c1575cdbf1c9140 SHA512 753ad4b95db25c1ad284ceb802b03db9724f2a1c1f4522f252428f8ae7c6771361b6a38d070c2ce989bec9538471529cdd92c925501a0f8f4f1bb5e6d8ef3733
diff --git a/dev-ruby/puppet_forge/metadata.xml b/dev-ruby/puppet_forge/metadata.xml
new file mode 100644
index 000000000000..4c2806a19ef9
--- /dev/null
+++ b/dev-ruby/puppet_forge/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Tools that can be used to access Forge API information on Modules,
+ Users, and Releases. As well as download, unpack, and install
+ Releases to a directory.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">puppetlabs/semantic_puppet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild b/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
new file mode 100644
index 000000000000..7223fbcbc0f0
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/faraday-0.9.0:0
+ >=dev-ruby/faraday_middleware-0.9.0:0
+ >=dev-ruby/gettext-setup-0.11:0
+ dev-ruby/archive-tar-minitar
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+}