summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/racc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/Manifest3
-rw-r--r--dev-ruby/racc/metadata.xml5
-rw-r--r--dev-ruby/racc/racc-1.4.11.ebuild66
-rw-r--r--dev-ruby/racc/racc-1.4.12.ebuild66
-rw-r--r--dev-ruby/racc/racc-1.4.9.ebuild61
5 files changed, 201 insertions, 0 deletions
diff --git a/dev-ruby/racc/Manifest b/dev-ruby/racc/Manifest
new file mode 100644
index 000000000000..82f34e5e99e7
--- /dev/null
+++ b/dev-ruby/racc/Manifest
@@ -0,0 +1,3 @@
+DIST racc-1.4.11.gem 113664 SHA256 1e2e420d5e2e4b9f2b352e9b2828448a2ee13a16fdebf6a7e863252b5054c840 SHA512 147c3c0ade40ec5544397a9dbf8579514d97145c2cc9f4e16508d41265c1b5cd6fc986c09367792592b5ab6b274e271eb7dded02ea9c398eadafb8addda4ef0c WHIRLPOOL e54b553547bf13816033c103a4de79e7e5bd50bf30b58a7525a059ce0556071f01ee6658ad00febbc024314f322ce114b41864d1833ce8bc282519fe5c868f40
+DIST racc-1.4.12.gem 115712 SHA256 bd9a6b06cf502abfdd7823c833ba69b74d038e8d365a5ce42d502f528f531db0 SHA512 7ae244127ba80ef07e1e2cabc1ec4c7c306b93d155d89e95ba425139c3ca24fdbc3c8cef3958b344a0b821fdfc36e25524d8b27de7f8a01ae2f1732edb11987f WHIRLPOOL 5c34ab9ab841f2062d697f7005e05a4b5bc54c8e210543ac4cc917f0a331cc8c823da9976b1f013b2a54664009e5bdc57d04da86d06882ec288438a304583642
+DIST racc-1.4.9.gem 109056 SHA256 f9d53caeb1ff5ac633a270a45478e585e6e054c44f6da28415f3432caf8f61d5 SHA512 84dfe85c7f0054ee6b2895b7ae3d28bebb51183c023457f8006b13b50a10a74e0f97ab92e3724a5c492dae9cebadb6f9e6d78e32add6bb11b07dd25459b7a7c2 WHIRLPOOL 1ab62401c403044d45b292dec12257b25847b7577d11bdd795fb7946720492356ffed43686fca288afad9ddce47cd8735bf0e62c9b297cbcbb2b1680764c805e
diff --git a/dev-ruby/racc/metadata.xml b/dev-ruby/racc/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/racc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/racc/racc-1.4.11.ebuild b/dev-ruby/racc/racc-1.4.11.ebuild
new file mode 100644
index 000000000000..c82d171ee620
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="https://github.com/tenderlove/racc"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( >=dev-ruby/minitest-4.0:0 )"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+
+ # Use a version of the minitest gem that works consistently accross
+ # all ruby versions.
+ sed -i -e '2i gem "minitest", "~>4.0"' test/helper.rb || die
+}
+
+each_ruby_prepare() {
+ ${RUBY} -Cext/racc extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}
diff --git a/dev-ruby/racc/racc-1.4.12.ebuild b/dev-ruby/racc/racc-1.4.12.ebuild
new file mode 100644
index 000000000000..4f4d11be291b
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="https://github.com/tenderlove/racc"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( >=dev-ruby/minitest-4.0:0 )"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+
+ # Use a version of the minitest gem that works consistently accross
+ # all ruby versions.
+ sed -i -e '2i gem "minitest", "~>4.0"' test/helper.rb || die
+}
+
+each_ruby_prepare() {
+ ${RUBY} -Cext/racc extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}
diff --git a/dev-ruby/racc/racc-1.4.9.ebuild b/dev-ruby/racc/racc-1.4.9.ebuild
new file mode 100644
index 000000000000..d830e70422b0
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+}
+
+each_ruby_prepare() {
+ ${RUBY} -Cext/racc extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}