summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/slim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/slim')
-rw-r--r--dev-ruby/slim/Manifest2
-rw-r--r--dev-ruby/slim/metadata.xml5
-rw-r--r--dev-ruby/slim/slim-2.0.3.ebuild40
-rw-r--r--dev-ruby/slim/slim-2.1.0.ebuild42
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-ruby/slim/Manifest b/dev-ruby/slim/Manifest
new file mode 100644
index 000000000000..928f277af08c
--- /dev/null
+++ b/dev-ruby/slim/Manifest
@@ -0,0 +1,2 @@
+DIST slim-2.0.3.gem 80896 SHA256 ba637becab0090feb16923c808ccf92ab42728eb1799e2bed45d7ca2e34e47fc SHA512 b519bde5725f0eae37f0aa5b0eef99f62749ff19ee17fc87291c5cd38c053106aa57fabc0ead05992c3316c509381c5bb30a9ac42b8584f99beb7f3e59c91bdf WHIRLPOOL 331dec490db9a2d145006e57d072a86eb8b0e45c8fad81fd6ab5bea5b3a2da9cac248fa7dce679f67d3c46f95a869b0ffd981f9d7d943518f7025651172946dc
+DIST slim-2.1.0.gem 92160 SHA256 de574c991afb2d2b3e081e9d1e4f4e20b339d3b2895b51f7bf022a35a82acd6b SHA512 a092689e62f1189aac9b6657572f76ee9915f1dbfcea7ed90c07386958cbeb6c974d25b7bc85f4cc6887312ab373487618e8dfd8e0f2b9f4dbd0574b0f4b928f WHIRLPOOL a7d141d7c9ce2e88770cc9ffb590465b0d597da1dd3df858a0e0843dc9b182426cc28793df9f56d06f770aff91208433c8fbdef8e5d9780c22edf91d2474989b
diff --git a/dev-ruby/slim/metadata.xml b/dev-ruby/slim/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/slim/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/slim/slim-2.0.3.ebuild b/dev-ruby/slim/slim-2.0.3.ebuild
new file mode 100644
index 000000000000..1f212728636c
--- /dev/null
+++ b/dev-ruby/slim/slim-2.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A template language whose goal is reduce the syntax to the essential parts without becoming cryptic"
+HOMEPAGE="http://slim-lang.com/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/tilt-1.3.3:0
+ >=dev-ruby/temple-0.6.6:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"
+
+ruby_add_bdepend "test? ( dev-ruby/sass )"
+
+all_ruby_prepare() {
+ # This sinatra code expects tests to be installed but we strip those.
+ sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die
+
+ # Avoid tests for things we don't have.
+ sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
+ -e '/test_render_with_wiki/,/^ end/ s:^:#:' \
+ -e '/test_render_with_creole/,/^ end/ s:^:#:' \
+ -e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
+
+}
diff --git a/dev-ruby/slim/slim-2.1.0.ebuild b/dev-ruby/slim/slim-2.1.0.ebuild
new file mode 100644
index 000000000000..81675d7c4e6d
--- /dev/null
+++ b/dev-ruby/slim/slim-2.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A template language whose goal is reduce the syntax to the essential parts without becoming cryptic"
+HOMEPAGE="http://slim-lang.com/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/tilt-1.3.3:0
+ >=dev-ruby/temple-0.6.6:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"
+
+ruby_add_bdepend "test? ( dev-ruby/sass )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # This sinatra code expects tests to be installed but we strip those.
+ sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die
+
+ # Avoid tests for things we don't have.
+ sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
+ -e '/test_render_with_wiki/,/^ end/ s:^:#:' \
+ -e '/test_render_with_creole/,/^ end/ s:^:#:' \
+ -e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
+
+}