summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/stamp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/stamp')
-rw-r--r--dev-ruby/stamp/Manifest2
-rw-r--r--dev-ruby/stamp/metadata.xml8
-rw-r--r--dev-ruby/stamp/stamp-0.5.0-r1.ebuild41
-rw-r--r--dev-ruby/stamp/stamp-0.6.0.ebuild35
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ruby/stamp/Manifest b/dev-ruby/stamp/Manifest
new file mode 100644
index 000000000000..e8286517bd39
--- /dev/null
+++ b/dev-ruby/stamp/Manifest
@@ -0,0 +1,2 @@
+DIST stamp-0.5.0.tar.gz 9022 SHA256 7346d95697a8eabe5d8e769bb098e1ff01bd1746f096176411ceba0c4c007ba0 SHA512 961121e2305d9948b003c12a16737c3a43235fc508bc1d2dd668bb7fc68893251c8575152aa61cea24617c9ce74c99c080b41353f81d9e70ab355e6e9f2365c8 WHIRLPOOL 5688685f0015c055d4830a1ec9b8b88cd81741710ac8e6623b0cfd466877f726beeeb20a6a105adaf25bc6f746083898b3c830e2f7de5de0c7ac305678f7a340
+DIST stamp-0.6.0.tar.gz 9099 SHA256 2b332424813c9bece7d61e7fa73c511802929fd9fe1349bc9ac58552648de63e SHA512 2f467444bad3c8932aeaeda061796ee3469b16d908027325efa28f7da005c8a4c8c95f0d3b84b6b1040bf5e5fe4114fc4779e3c9efc6c00817a050c13be62472 WHIRLPOOL bc345c03789669e809a7b480d8876cfa3afbef2a945583925bee204e087d2b3ec28b1a87dc569dad8b7c4633e01a40d9349d75616633c2f5b28cba4c5530ed12
diff --git a/dev-ruby/stamp/metadata.xml b/dev-ruby/stamp/metadata.xml
new file mode 100644
index 000000000000..643300f6cc6d
--- /dev/null
+++ b/dev-ruby/stamp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jeremyw/stamp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stamp/stamp-0.5.0-r1.ebuild b/dev-ruby/stamp/stamp-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..98d799a52d6e
--- /dev/null
+++ b/dev-ruby/stamp/stamp-0.5.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="cucumber"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Date and time formatting for humans"
+HOMEPAGE="https://github.com/jeremyw/stamp"
+SRC_URI="https://github.com/jeremyw/stamp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/redcarpet )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die "sed failed"
+ sed -i -e '/bundler/,+7d' features/support/env.rb || die "sed failed"
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}
diff --git a/dev-ruby/stamp/stamp-0.6.0.ebuild b/dev-ruby/stamp/stamp-0.6.0.ebuild
new file mode 100644
index 000000000000..36d1816f4bb0
--- /dev/null
+++ b/dev-ruby/stamp/stamp-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="cucumber"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Date and time formatting for humans"
+HOMEPAGE="https://github.com/jeremyw/stamp"
+SRC_URI="https://github.com/jeremyw/stamp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die "sed failed"
+ sed -i -e '/bundler/,+7d' features/support/env.rb || die "sed failed"
+}