summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-11 10:10:41 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-11 10:31:31 +0100
commit9c5e92ab631bb2a20a862237c3f226f9d1b7aa75 (patch)
treeda78ddc73b6659ef0427b1a525e51b987ea4073a /dev-ruby/strptime
parentdev-ruby/strptime: cleanup (diff)
downloadgentoo-9c5e92ab631bb2a20a862237c3f226f9d1b7aa75.tar.gz
gentoo-9c5e92ab631bb2a20a862237c3f226f9d1b7aa75.tar.bz2
gentoo-9c5e92ab631bb2a20a862237c3f226f9d1b7aa75.zip
dev-ruby/strptime: add ruby30; fix extension
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/strptime')
-rw-r--r--dev-ruby/strptime/strptime-0.2.5-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/strptime/strptime-0.2.5-r1.ebuild b/dev-ruby/strptime/strptime-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..807ebce45fec
--- /dev/null
+++ b/dev-ruby/strptime/strptime-0.2.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/strptime/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/strptime
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast strptime/strftime engine which uses VM"
+HOMEPAGE="https://github.com/nurse/strptime"
+SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}