summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-02 10:59:16 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-03 08:13:02 +0100
commitb8c1f3f97c22b87b57cc2070b78d6d22eec208f2 (patch)
tree957e05f9e5ae8d4322226e9d2d9afbbbda5057b8 /dev-ruby/typhoeus
parentvirtual/dist-kernel: Stabilize 5.15.80 x86, #883321 (diff)
downloadgentoo-b8c1f3f97c22b87b57cc2070b78d6d22eec208f2.tar.gz
gentoo-b8c1f3f97c22b87b57cc2070b78d6d22eec208f2.tar.bz2
gentoo-b8c1f3f97c22b87b57cc2070b78d6d22eec208f2.zip
dev-ruby/typhoeus: update EAPI 7 -> 8, add ruby30
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/typhoeus')
-rw-r--r--dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..6dc99f1ce694
--- /dev/null
+++ b/dev-ruby/typhoeus/typhoeus-1.4.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md UPGRADE.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Runs HTTP requests in parallel while cleanly encapsulating handling logic"
+HOMEPAGE="https://rubygems.org/gems/typhoeus/
+ https://github.com/typhoeus/typhoeus"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/ethon-0.9.0"
+
+ruby_add_bdepend "test? ( dev-ruby/json || ( dev-ruby/faraday:1 >=dev-ruby/faraday-0.9 ) >=dev-ruby/sinatra-1.3 >=dev-ruby/redis-3.0 >=dev-ruby/dalli-2.7.9 )"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+ sed -i -e '3igem "faraday", "<2"; require "timeout"' spec/spec_helper.rb || die
+ sed -i -e '/Rack::Handler::WEBrick/ s/options/\*\*options/' spec/support/localhost_server.rb || die
+}