summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/web-console
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/web-console')
-rw-r--r--dev-ruby/web-console/Manifest2
-rw-r--r--dev-ruby/web-console/metadata.xml8
-rw-r--r--dev-ruby/web-console/web-console-2.1.3.ebuild40
-rw-r--r--dev-ruby/web-console/web-console-2.2.1.ebuild40
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-ruby/web-console/Manifest b/dev-ruby/web-console/Manifest
new file mode 100644
index 000000000000..216fcd58ce9e
--- /dev/null
+++ b/dev-ruby/web-console/Manifest
@@ -0,0 +1,2 @@
+DIST web-console-2.1.3.tar.gz 32705 SHA256 558c97a2809282a7d397a6d9d6485d1db850c844c28ab4b5f40479a7a50781c5 SHA512 91cff2f02a0c498f97a4be344d0bf5b4f9aa6a2521f7511739fb71c61a45d309fc5b4a9ee4881311129a9f7526a9ec51c87258d5d3abeb77d00dc6c4c46516ff WHIRLPOOL fc4109fe6a517075b6d140cc38dbe56b9d52b4906be38c011e3dced5e1354cc909c2f753d102cf96fd184815a363a49c091545bccfe197d9cc721baa9f0fadfb
+DIST web-console-2.2.1.tar.gz 37554 SHA256 147727d34bd4165a0c214a7f2761e2999dd4355f11661acb6da43f414fa33f9e SHA512 832838a975f805b8c35fb03233fc1a39c90ba5c36908b4e3fb355bcad3b7b7113cbbb2544474948453353a89953cdd2fecdd71bdbeab5ab06f71bd7f67a3be31 WHIRLPOOL d4d1e55a1864daab086e86e33debc800afb90c099556199c7cc13bfbd25098420df1756171f2722aecb449fec1df60a3f79725216ff3b28b8658de3369f0aa10
diff --git a/dev-ruby/web-console/metadata.xml b/dev-ruby/web-console/metadata.xml
new file mode 100644
index 000000000000..3e3a9136e079
--- /dev/null
+++ b/dev-ruby/web-console/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/web-console</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/web-console/web-console-2.1.3.ebuild b/dev-ruby/web-console/web-console-2.1.3.ebuild
new file mode 100644
index 000000000000..623943a1e641
--- /dev/null
+++ b/dev-ruby/web-console/web-console-2.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.markdown README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A debugging tool for your Ruby on Rails applications"
+HOMEPAGE="https://github.com/rails/web-console"
+SRC_URI="https://github.com/rails/web-console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-4.0:*
+ >=dev-ruby/binding_of_caller-0.7.2
+ >=dev-ruby/railties-4.0:*
+ >=dev-ruby/sprockets-rails-2.0:* <dev-ruby/sprockets-rails-4.0:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ >=dev-ruby/rails-4.0
+ dev-ruby/sqlite3
+ dev-ruby/mocha
+ dev-ruby/simplecov
+)"
+
+all_ruby_prepare() {
+ # Use an installed rails version rather than live source from github.
+ sed -i -e '/rails/ s/,/#/' Gemfile || die
+}
diff --git a/dev-ruby/web-console/web-console-2.2.1.ebuild b/dev-ruby/web-console/web-console-2.2.1.ebuild
new file mode 100644
index 000000000000..623943a1e641
--- /dev/null
+++ b/dev-ruby/web-console/web-console-2.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.markdown README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A debugging tool for your Ruby on Rails applications"
+HOMEPAGE="https://github.com/rails/web-console"
+SRC_URI="https://github.com/rails/web-console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-4.0:*
+ >=dev-ruby/binding_of_caller-0.7.2
+ >=dev-ruby/railties-4.0:*
+ >=dev-ruby/sprockets-rails-2.0:* <dev-ruby/sprockets-rails-4.0:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ >=dev-ruby/rails-4.0
+ dev-ruby/sqlite3
+ dev-ruby/mocha
+ dev-ruby/simplecov
+)"
+
+all_ruby_prepare() {
+ # Use an installed rails version rather than live source from github.
+ sed -i -e '/rails/ s/,/#/' Gemfile || die
+}