summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-02 06:49:48 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-02 06:49:48 +0200
commitdff4a54ee106281914f57e23b30184b83ae8aa97 (patch)
tree1fb4419c510158ec78a27f14ba0d85d7c1a9f108 /dev-ruby
parentdev-ruby/haml-rails: add 2.1.0 (diff)
downloadgentoo-dff4a54ee106281914f57e23b30184b83ae8aa97.tar.gz
gentoo-dff4a54ee106281914f57e23b30184b83ae8aa97.tar.bz2
gentoo-dff4a54ee106281914f57e23b30184b83ae8aa97.zip
dev-ruby/hiera-eyaml: add 3.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hiera-eyaml/Manifest1
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.4.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/hiera-eyaml/Manifest b/dev-ruby/hiera-eyaml/Manifest
index 8bb06486fe67..4168aa69aba0 100644
--- a/dev-ruby/hiera-eyaml/Manifest
+++ b/dev-ruby/hiera-eyaml/Manifest
@@ -1 +1,2 @@
DIST hiera-eyaml-3.3.0.tar.gz 60385 BLAKE2B 222c0e531a0b713a0d996895168229468f131d9ce1dd786ef8337b5d9ec8a322e336bd12191253fb09e11d60682491081acd5b946a7257b6183e6533fe924811 SHA512 4bb81b87244177a4ab3ca80d0a5e67a8e6534dbdf4d489ca9f918ea97981e50d203e441cff6a35996878b6fa91815e00bdb8261e19359bb3f00efc14b1f25e0d
+DIST hiera-eyaml-3.4.0.tar.gz 60920 BLAKE2B 73a2a5c15d79b8084f226173667fc29875ea4614a09030171f81a1b2c632d45071e8952765afb9900c695643016117f9e1a28f9cefe7a19a9de67315ed4d139b SHA512 64443cc49e66dd95cb85d5a2e26a50b5c60ef78dc21354fb5a3760f4e1f0005936d46ff54232e2f2e1b250628a4844b79a8ca267c4d72ab53ef318cde10a074b
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.4.0.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.4.0.ebuild
new file mode 100644
index 000000000000..db643f2513ac
--- /dev/null
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-3.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md PLUGINS.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Encrypted YAML backend for hiera"
+HOMEPAGE="https://github.com/voxpupuli/hiera-eyaml"
+SRC_URI="https://github.com/voxpupuli/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/highline-1.6.19:*
+ dev-ruby/optimist
+"
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ ~dev-util/aruba-0.6.2
+ dev-ruby/hiera-eyaml-plaintext
+)"
+
+BDEPEND+=" test? ( || ( app-admin/puppet-agent app-admin/puppet ) )"
+
+all_ruby_prepare() {
+ # Fix highline dependency to be compatible with more versions.
+ sed -i -e '/highline/ s/~>/>=/' \
+ -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e "s:/tmp:${T}:" \
+ features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
+ features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
+ features/sandbox/puppet-envvar/environments/local/modules/test/manifests/run.pp \
+ features/puppet.feature
+}
+
+each_ruby_prepare() {
+ # Run tests with the correct ruby interpreter
+ sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
+
+}
+
+each_ruby_test() {
+ CUCUMBER_PUBLISH_QUIET=true ${RUBY} -S cucumber --format progress features || die
+}