summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-26 19:48:59 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-26 19:50:24 +0100
commit0d86f91154239320e934159ff677c376618a7535 (patch)
tree0422f6dd908b6d53f97be2c1ffec330c4644aeab /dev-tcltk/tclpython
parentnet-mail/mailutils: Stabilize 3.15 sparc, #880557 (diff)
downloadgentoo-0d86f91154239320e934159ff677c376618a7535.tar.gz
gentoo-0d86f91154239320e934159ff677c376618a7535.tar.bz2
gentoo-0d86f91154239320e934159ff677c376618a7535.zip
dev-tcltk/tclpython: update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/896908 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tcltk/tclpython/tclpython-5.0-r2.ebuild b/dev-tcltk/tclpython/tclpython-5.0-r2.ebuild
new file mode 100644
index 000000000000..0731a9cc5200
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-5.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="https://github.com/amykyta3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake PKG_NAME=tclpython3 CC="$(tc-getCC)" \
+ MYCFLAGS="${CFLAGS}" \
+ MYLDFLAGS="${LDFLAGS} $(python_get_library_path)"
+}
+
+src_test() {
+ emake PKG_NAME=tclpython3 CC="$(tc-getCC)" test
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+ doins -r build/tclpython3/tclpython3
+ fperms 775 /usr/$(get_libdir)/tclpython3/tclpython3.so.${PV}
+ dosym tclpython3.so.${PV} /usr/$(get_libdir)/tclpython3/tclpython3.so
+
+ dodoc README.md VERSION.md
+}