summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2016-03-06 19:37:40 -0800
committerDaniel Campbell <zlg@gentoo.org>2016-03-06 19:38:13 -0800
commit9dcea2843d9a4a175d3f1f44e8b7a823defa1c2b (patch)
treede62e715f361aa6fd203ec0a1687b67b8d774a7d /dev-tcltk/tclpython
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-9dcea2843d9a4a175d3f1f44e8b7a823defa1c2b.tar.gz
gentoo-9dcea2843d9a4a175d3f1f44e8b7a823defa1c2b.tar.bz2
gentoo-9dcea2843d9a4a175d3f1f44e8b7a823defa1c2b.zip
dev-tcltk/tclpython: Revbump, correcting DEPEND
Gentoo-Bug: 575518 Gentoo-Bug-URL: https://bugs.gentoo.org/575518 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r5.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r5.ebuild
new file mode 100644
index 000000000000..a8787e6cd686
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-4.1-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-lang/tcl:0=
+ sys-devel/binutils:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.patch
+)
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+}
+
+src_compile() {
+ local cfile="tclpython tclthread"
+ for src in ${cfile}; do
+ compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
+ einfo "${compile}"
+ eval "${compile}" || die
+ done
+
+ link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_LIBS) -ltcl"
+ einfo "${link}"
+ eval "${link}" || die
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/tclpython
+ doins tclpython.so.${PV} pkgIndex.tcl
+ fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
+ dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so
+
+ dodoc CHANGES INSTALL README
+ dohtml tclpython.htm
+}