summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-09-15 19:11:53 +0800
committerJason Zaman <perfinion@gentoo.org>2018-09-15 23:57:43 +0800
commit98fb94de90c16adbe43807b4388ed5b90ff61138 (patch)
treeaa2912ff723e677555da954025fae8a80764213e /dev-util/bazel
parentdev-util/bazel: bump 0.17.1 (diff)
downloadgentoo-98fb94de90c16adbe43807b4388ed5b90ff61138.tar.gz
gentoo-98fb94de90c16adbe43807b4388ed5b90ff61138.tar.bz2
gentoo-98fb94de90c16adbe43807b4388ed5b90ff61138.zip
dev-util/bazel: drop old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.14.1.ebuild141
2 files changed, 0 insertions, 142 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index bd8c88be06fd..ba84490ec066 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -1,4 +1,3 @@
-DIST bazel-0.14.1-dist.zip 89415405 BLAKE2B 7be5d4630d024d235a66f6bdf495c282b04a4034dde156c50d37a7e2eb3bf98df0caead7887f421b664fe92486e6baa5cd90e61b1e82b07b1691dc509ab93a68 SHA512 02c7125438f060d8e5e25b91ce3ca76fac6681b4f12033d807955a4ca5a5c22a3508a7229581b7349f35f343911f8408f43f8d78d54601277576dd32539e4681
DIST bazel-0.16.0-dist.zip 89720984 BLAKE2B be8ad9c94b13dd8d1d1de76ed67a3a695a2541327b8cb8a4d27b9279c065cb351d6b2d5785024d11a163bfd4697fb1375b350c8220387ab79db7e95537def5c3 SHA512 89cefed69df1cae7076673900546199427fab3508aad1f0347b9da38153b6b1566b19a4c205055f41ca431fd9444ec772c86bc32fbff0da0485a5e5f11728932
DIST bazel-0.17.1-dist.zip 79229870 BLAKE2B 0f149ac881dc1bc02ab5b07590620d19921034d6d5fb88bf46b0a10e0eceac1ba0f33181e9912d342c01e551bf94e38a13e4252762e6b4e7800ec1527a970f76 SHA512 b8c2292baf67b0b8a85811145ac220084975a2bcd2f2a9f461e83589296c56166886f91a32cde343762247a9c3a04100b3f86a8f969d880f641f88183a804e6b
DIST google-desugar_jdk_libs-f5e6d80c6b4ec6b0a46603f72b015d45cf3c11cd.zip 1056996 BLAKE2B bf168c41a9958bcdc679a40d1e88911c6af0e47207362204326b712e0129b37348360a855f44af8b76acc46108ac89a707d0c0f793500c513a919070248939b9 SHA512 40cb9ffcaa3c57c69bcbec7b070fad5865e7317817049b7588dd42899054eb97cd17cb0019df99ad2324ed8e2efd8334cd83ace758a4c2d3f453503ccf54a91e
diff --git a/dev-util/bazel/bazel-0.14.1.ebuild b/dev-util/bazel/bazel-0.14.1.ebuild
deleted file mode 100644
index b972de19c2d7..000000000000
--- a/dev-util/bazel/bazel-0.14.1.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1 java-pkg-2 multiprocessing
-
-DESCRIPTION="Fast and correct automated build system"
-HOMEPAGE="http://bazel.io/"
-
-bazel_external_uris="https://github.com/google/desugar_jdk_libs/archive/f5e6d80c6b4ec6b0a46603f72b015d45cf3c11cd.zip -> google-desugar_jdk_libs-f5e6d80c6b4ec6b0a46603f72b015d45cf3c11cd.zip"
-SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip
- ${bazel_external_uris}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples tools zsh-completion"
-# strip corrupts the bazel binary
-RESTRICT="strip"
-RDEPEND="virtual/jdk:1.8"
-DEPEND="${RDEPEND}
- app-arch/unzip
- app-arch/zip"
-
-S="${WORKDIR}"
-
-bazel-get-flags() {
- local i fs=()
- for i in ${CFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- done
- for i in ${CXXFLAGS}; do
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${CPPFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${LDFLAGS}; do
- fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
- done
- echo "${fs[*]}"
-}
-
-load_distfiles() {
- # Populate the bazel distdir to fetch from since it cannot use the network
- local s d uri rename
- mkdir -p "${T}/bazel-distdir" || die "failed to create distdir"
-
- while read uri rename d; do
- [[ -z "$uri" ]] && continue
- if [[ "$rename" == "->" ]]; then
- s="${uri##*/}"
- einfo "Copying $d to bazel distdir $s ..."
- else
- s="${uri##*/}"
- d="${s}"
- einfo "Copying $d to bazel distdir ..."
- fi
- cp "${DISTDIR}/${d}" "${T}/bazel-distdir/${s}" || die
- done <<< "${bazel_external_uris}"
-}
-
-pkg_setup() {
- echo ${PATH} | grep -q ccache && \
- ewarn "${PN} usually fails to compile with ccache, you have been warned"
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- # Only unpack the main distfile
- unpack ${P}-dist.zip
-}
-
-src_prepare() {
- load_distfiles
- default
-
- # F: fopen_wr
- # S: deny
- # P: /proc/self/setgroups
- # A: /proc/self/setgroups
- # R: /proc/24939/setgroups
- # C: /usr/lib/systemd/systemd
- addpredict /proc
-
- # Use standalone strategy to deactivate the bazel sandbox, since it
- # conflicts with FEATURES=sandbox.
- cat > "${T}/bazelrc" <<-EOF
- build --verbose_failures
- build --spawn_strategy=standalone --genrule_strategy=standalone
-
- build --experimental_distdir=${T}/bazel-distdir
- build --jobs=$(makeopts_jobs) $(bazel-get-flags)
-
- test --verbose_failures --verbose_test_summary
- test --spawn_strategy=standalone --genrule_strategy=standalone
- EOF
-
- echo "import ${T}/bazelrc" >> "${S}/.bazelrc"
-}
-
-src_compile() {
- export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs)"
- VERBOSE=yes ./compile.sh || die
- output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
- mv bazel-bin/scripts/bazel-complete.bash output/ || die
-}
-
-src_test() {
- output/bazel test \
- --verbose_failures \
- --spawn_strategy=standalone \
- --genrule_strategy=standalone \
- --verbose_test_summary \
- examples/cpp:hello-success_test || die
-}
-
-src_install() {
- output/bazel shutdown
- dobin output/bazel
- newbashcomp output/bazel-complete.bash ${PN}
- bashcomp_alias ${PN} ibazel
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins scripts/zsh_completion/_bazel
- fi
- if use examples; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
- # could really build tools but I don't know which ones
- # are actually used
- if use tools; then
- docinto tools
- dodoc -r tools/*
- docompress -x /usr/share/doc/${PF}/tools
- fi
-}