summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-05-29 16:36:52 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-05-29 17:11:17 -0700
commit48ecd5008646b9d70b728146f12e232b47794385 (patch)
tree3242ed6e38b3a1c28e30b4e72f61c59f57fff9fc /dev-util/buildbot-worker
parentdev-util/buildbot-www: Bump to 3.5.0 (diff)
downloadgentoo-48ecd5008646b9d70b728146f12e232b47794385.tar.gz
gentoo-48ecd5008646b9d70b728146f12e232b47794385.tar.bz2
gentoo-48ecd5008646b9d70b728146f12e232b47794385.zip
dev-util/buildbot-worker: Bump to 3.5.0
Update deps in 9999 Fix bug 845300 Closes: https://bugs.gentoo.org/845300 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-worker')
-rw-r--r--dev-util/buildbot-worker/Manifest1
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-3.5.0.ebuild127
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-9999.ebuild3
-rw-r--r--dev-util/buildbot-worker/files/buildbot_worker.initd24
4 files changed, 133 insertions, 2 deletions
diff --git a/dev-util/buildbot-worker/Manifest b/dev-util/buildbot-worker/Manifest
index 2143d4df82fc..8cdd489c081c 100644
--- a/dev-util/buildbot-worker/Manifest
+++ b/dev-util/buildbot-worker/Manifest
@@ -1 +1,2 @@
DIST buildbot-worker-3.4.0.tar.gz 102910 BLAKE2B c38a806e8d0475a8c18176310f628b829fc359f013b315e82715e71071213fe4a0cdf38273ad7df39a66675f4ebc9fb1881fb990290f2bbedf4c8777ec93d4dc SHA512 411a2bf496622c2b9a3e0dea1ea8a71b347566010086c57ffc5d1114546cc5052af39a8ff7b10ffe6e7afdb6fc8ff73a9ffba23b96a76ff1cc0e3eff81cc59a7
+DIST buildbot-worker-3.5.0.tar.gz 111349 BLAKE2B 90d193fb89ac65ca03274e0ad5c7fde8fc478bb932ccc4240495437f79171d49f623f50731c7619336386b7d1d7df3f955e10bf006ad86b8dcf294d75c874774 SHA512 1df67b6332753f91179863cca76b0578e4f36954e0aa4eb9c28f98d6451d6972e247849fb9d4e20b753b5702d100406b306ce4982181510ad81de0d35a9828ed
diff --git a/dev-util/buildbot-worker/buildbot-worker-3.5.0.ebuild b/dev-util/buildbot-worker/buildbot-worker-3.5.0.ebuild
new file mode 100644
index 000000000000..7bf98bc994af
--- /dev/null
+++ b/dev-util/buildbot-worker/buildbot-worker-3.5.0.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit readme.gentoo-r1 distutils-r1
+
+MY_V="${PV/_p/.post}"
+MY_P="${PN}-${MY_V}"
+
+DESCRIPTION="BuildBot Worker (slave) Daemon"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-worker/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/buildbot
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ !<dev-util/buildbot-1.0.0
+"
+BDEPEND="
+ >=dev-python/msgpack-0.6.0[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
+to support starting buildbot_worker through Gentoo's init system. To use this,
+execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+Set up your build worker following the documentation, make sure the
+resulting directories are owned by the \"buildbot\" user and point
+\"${ROOT}/etc/conf.d/buildbot_worker.myinstance\" at the right location.
+The scripts can run as a different user if desired."
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial buildbot_worker || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/buildbot-worker.1
+
+ newconfd "${FILESDIR}/buildbot_worker.confd2" buildbot_worker
+ newinitd "${FILESDIR}/buildbot_worker.initd2" buildbot_worker
+
+ dodir /var/lib/buildbot_worker
+ cp "${FILESDIR}/buildbot.tac.sample" "${D}/var/lib/buildbot_worker"|| die "Install failed!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "More than one instance of a buildbot_worker can be run simultaneously."
+ ewarn " Note that \"BASEDIR\" in the buildbot_worker configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildbot_worker instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildbot_worker /etc/init.d/buildbot_worker.myinstance"
+ ewarn " rc-update add buildbot_worker.myinstance default"
+ ewarn " /etc/init.d/buildbot_worker.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildbot_worker@myinstance.service"
+ ewarn " systemctl enable buildbot_worker.target"
+ ewarn " systemctl start buildbot_worker.target"
+ fi
+}
+
+pkg_config() {
+ local buildworker_path="/var/lib/buildbot_worker"
+ local log_path="/var/log/buildbot_worker"
+
+ einfo "This will prepare a new buildbot_worker instance in ${buildworker_path}."
+ einfo "Press Control-C to abort."
+
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
+
+ local instance_path="${buildworker_path}/${instance_name}"
+ local instance_log_path="${log_path}/${instance_name}"
+
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
+
+ if [[ ! -d "${instance_path}" ]]; then
+ mkdir --parents "${instance_path}" || die "Unable to create directory ${buildworker_path}"
+ fi
+ chown --recursive buildbot:buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ cp "${buildworker_path}/buildbot.tac.sample" "${instance_path}/buildbot.tac" \
+ || die "Moving sample configuration failed"
+ ln --symbolic --relative "/etc/init.d/buildbot_worker" "/etc/init.d/buildbot_worker.${instance_name}" \
+ || die "Unable to create link to init file"
+
+ if [[ ! -d "${instance_log_path}" ]]; then
+ mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ chown --recursive buildbot:buildbot "${instance_log_path}" \
+ || die "Setting permissions for instance failed"
+ fi
+ ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
+ || die "Unable to create link to log file"
+
+ einfo "Successfully created a buildbot_worker instance at ${instance_path}."
+ einfo "To change the default settings edit the buildbot.tac file in this directory."
+}
diff --git a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
index 18ee776e0e52..511a5ed0a21b 100644
--- a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
+++ b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
@@ -20,14 +20,17 @@ RESTRICT="!test? ( test )"
RDEPEND="
acct-user/buildbot
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
!<dev-util/buildbot-1.0.0
"
BDEPEND="
+ >=dev-python/msgpack-0.6.0[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
)
"
diff --git a/dev-util/buildbot-worker/files/buildbot_worker.initd2 b/dev-util/buildbot-worker/files/buildbot_worker.initd2
index 453d207e5d88..4ebfdd452926 100644
--- a/dev-util/buildbot-worker/files/buildbot_worker.initd2
+++ b/dev-util/buildbot-worker/files/buildbot_worker.initd2
@@ -1,8 +1,8 @@
#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-BUILDWORKER_NAME=${RC_SVCNAME:16}
+BUILDWORKER_NAME=${RC_SVCNAME#*.}
BUILDWORKER_PATH="${BASEDIR}/${BUILDWORKER_NAME}"
depend() {
need net