summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-05-08 10:34:17 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-05-12 11:15:03 -0700
commitca2041cb54d4fd8c2af7461043cbc13f37fcfb65 (patch)
tree22a8fe41f1ca4cca001657276d3bb8c5f75f75e0 /dev-util/buildbot
parentacct-user/buildbot: New dev-util/buildbot user (diff)
downloadgentoo-ca2041cb54d4fd8c2af7461043cbc13f37fcfb65.tar.gz
gentoo-ca2041cb54d4fd8c2af7461043cbc13f37fcfb65.tar.bz2
gentoo-ca2041cb54d4fd8c2af7461043cbc13f37fcfb65.zip
dev-util/buildbot: Version bump, adds python 3.7,3.8
metadata.xml: take maintainership Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/Manifest1
-rw-r--r--dev-util/buildbot/buildbot-2.7.0.ebuild216
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild47
-rw-r--r--dev-util/buildbot/files/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch26
-rw-r--r--dev-util/buildbot/files/pypugjs.patch84
-rw-r--r--dev-util/buildbot/metadata.xml5
6 files changed, 357 insertions, 22 deletions
diff --git a/dev-util/buildbot/Manifest b/dev-util/buildbot/Manifest
index 945e3fa1b8ab..9bdfbaf4fd39 100644
--- a/dev-util/buildbot/Manifest
+++ b/dev-util/buildbot/Manifest
@@ -1,3 +1,4 @@
DIST buildbot-0.9.12.tar.gz 3057832 BLAKE2B 8e1748739bacc3c884f353b2a1c798575e3ce5f451a1711ecf88a7c7e517da86d2e791748d31468a2bb07369022e96cb568518b7a8ce1d9e1cece0b6ab77eec8 SHA512 62459918267297b31b2a6416f72794c7a4ebdcb60de04ece1681f6b8be9debf161716cc70ad843fd468b23e02c521c0a0783a5a1e119d75648e107691d6b908d
DIST buildbot-1.1.2.tar.gz 3101168 BLAKE2B 35ec56440014015850a69324d475c4ca9555ad90da85b26a7a43eca74f08361137021aec72ddca37cbb24f21519ebf45948e66214291f356b4a1fbada7c0b3b8 SHA512 14c28d6fae18a10d89d41509635188d881ac76e7b61758481a9afbb22eb384d7ab5080383242e5850af13bfe46877985a91036270c3c4fbf01eafee5b7699815
DIST buildbot-1.3.0.tar.gz 3119185 BLAKE2B d366b83baad7e865481535a2462ceb222aadce6c90a6229e82a72bf86518b8ebb0624d8ac8b64867783d58b6e9033b942a1ccd31fd6664a2b527eac9f11ab852 SHA512 e5ecf3eafe428a188c2410d270ee9bd5afc39122e62d35747288cf85347368ab4a94190b4ff6fe687269dc19cc7b91d33be8d3e3b637741e421a2cbd83572830
+DIST buildbot-2.7.0.tar.gz 3175050 BLAKE2B 0a41eccaa4ca8df6396455049e8c09a1b2fe6cde3072da7fd3715f2769015944e8880f41dbe6750dd7b26bd863fb82f8e8d8c6540f9e1bf3ea4378f11adc973d SHA512 9946fe0b1591d51e5136d9458526918e872174afee79b5f1c333823ef1d2ddae66f017e9b57e26a2451da7ca7672720f32544c606ce5652d0825fae563779669
diff --git a/dev-util/buildbot/buildbot-2.7.0.ebuild b/dev-util/buildbot/buildbot-2.7.0.ebuild
new file mode 100644
index 000000000000..38c6ccf3ffdc
--- /dev/null
+++ b/dev-util/buildbot/buildbot-2.7.0.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit readme.gentoo-r1 systemd distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot build automation system"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot/"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~amd64-linux ~x86-linux"
+fi
+
+IUSE="crypt doc docker examples irc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/buildbot
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )
+ irc? (
+ dev-python/txrequests[${PYTHON_USEDEP}]
+ )
+ docker? (
+ >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ >=dev-python/sphinx-1.4.3[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-blockdiag[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx-jinja[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.12.48[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pypugjs[${PYTHON_USEDEP}]
+ dev-python/txrequests[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/treq[${PYTHON_USEDEP}]
+ dev-python/setuptools_trial[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )
+ )"
+# >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+
+S=${WORKDIR}/${MY_P}
+[[ ${PV} == *9999 ]] && S=${S}/master
+
+if [[ ${PV} != *9999 ]]; then
+ PATCHES=(
+ "${FILESDIR}/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch"
+ "${FILESDIR}/pypugjs.patch"
+ )
+fi
+
+distutils_enable_tests setup.py
+
+pkg_setup() {
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
+ to support starting buildbot through Gentoo's init system. To use this,
+ execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+ The scripts can run as a different user if desired."
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ #'man' target is currently broken
+ emake html
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildbot.1
+
+ if use doc; then
+ dohtml -r docs/_build/html/
+ # TODO: install man pages
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r docs/examples
+ fi
+
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildmaster.initd" buildmaster
+ systemd_dounit "${FILESDIR}/buildmaster.target"
+ systemd_newunit "${FILESDIR}/buildmaster_at.service" "buildmaster@.service"
+ systemd_install_serviced "${FILESDIR}/buildmaster_at.service.conf" "buildmaster@.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "Starting with buildbot-0.8.12-r2, more than one instance of buildmaster"
+ ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildmaster instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildmaster /etc/init.d/buildmaster.myinstance"
+ ewarn " rc-update add buildmaster.myinstance default"
+ ewarn " /etc/init.d/buildmaster.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildmaster@myinstance.service"
+ ewarn " systemctl enable buildmaster.target"
+ ewarn " systemctl start buildmaster.target"
+ elog
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the"
+ elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+ fi
+ elog
+ elog "In order to create a new instance of buildmaster, execute:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+}
+
+pkg_config() {
+ local buildmaster_path="/var/lib/buildmaster"
+ local log_path="/var/log/buildmaster"
+
+ einfo "This will prepare a new buildmaster instance in ${buildmaster_path}."
+ einfo "Press Control-C to abort."
+
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
+
+ local instance_path="${buildmaster_path}/${instance_name}"
+ local instance_log_path="${log_path}/${instance_name}"
+
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
+
+ local buildbot="/usr/bin/buildbot"
+ if [[ ! -d "${buildmaster_path}" ]]; then
+ mkdir --parents "${buildmaster_path}" || die "Unable to create directory ${buildmaster_path}"
+ fi
+ "${buildbot}" create-master "${instance_path}" &>/dev/null || die "Creating instance failed"
+ chown --recursive buildbot "${instance_path}" || die "Setting permissions for instance failed"
+ mv "${instance_path}/master.cfg.sample" "${instance_path}/master.cfg" \
+ || die "Moving sample configuration failed"
+ ln --symbolic --relative "/etc/init.d/buildmaster" "/etc/init.d/buildmaster.${instance_name}" \
+ || die "Unable to create link to init file"
+
+ if [[ ! -d "${instance_log_path}" ]]; then
+ mkdir --parents "${instance_log_path}" || die "Unable to create directory ${instance_log_path}"
+ fi
+ ln --symbolic --relative "${instance_log_path}/twistd.log" "${instance_path}/twistd.log" \
+ || die "Unable to create link to log file"
+
+ einfo "Successfully created a buildmaster instance at ${instance_path}."
+ einfo "To change the default settings edit the master.cfg file in this directory."
+}
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index d59c41b23e9b..38c6ccf3ffdc 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_REQ_USE="sqlite"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
[[ ${PV} == *9999 ]] && inherit git-r3
-inherit readme.gentoo-r1 user systemd distutils-r1
+inherit readme.gentoo-r1 systemd distutils-r1
MY_PV="${PV/_p/.post}"
MY_P="${PN}-${MY_PV}"
@@ -29,6 +31,7 @@ IUSE="crypt doc docker examples irc test"
RESTRICT="!test? ( test )"
RDEPEND="
+ acct-user/buildbot
>=dev-python/jinja-2.1[${PYTHON_USEDEP}]
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP}]
>=dev-python/autobahn-0.16.0[${PYTHON_USEDEP}]
@@ -38,12 +41,13 @@ RDEPEND="
>=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/txaio-2.2.2[${PYTHON_USEDEP}]
dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/zope-interface-4.1.1[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
crypt? (
>=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
>=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
dev-python/service_identity[${PYTHON_USEDEP}]
)
irc? (
@@ -51,46 +55,53 @@ RDEPEND="
)
docker? (
>=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
)
"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
doc? (
>=dev-python/sphinx-1.4.3[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-blockdiag[${PYTHON_USEDEP}]
dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
dev-python/pyenchant[${PYTHON_USEDEP}]
- >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
- <dev-python/docutils-0.13.0[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
dev-python/sphinx-jinja[${PYTHON_USEDEP}]
)
test? (
- >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
dev-python/moto[${PYTHON_USEDEP}]
- dev-python/boto3[${PYTHON_USEDEP}]
- dev-python/pyjade[${PYTHON_USEDEP}]
- dev-python/txgithub[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.12.48[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pypugjs[${PYTHON_USEDEP}]
dev-python/txrequests[${PYTHON_USEDEP}]
dev-python/lz4[${PYTHON_USEDEP}]
dev-python/treq[${PYTHON_USEDEP}]
dev-python/setuptools_trial[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
~dev-util/buildbot-worker-${PV}[${PYTHON_USEDEP}]
- >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/twisted-17.9.0[${PYTHON_USEDEP},crypt]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )
)"
+# >=dev-python/docker-py-2.2.0[${PYTHON_USEDEP}]
S=${WORKDIR}/${MY_P}
[[ ${PV} == *9999 ]] && S=${S}/master
if [[ ${PV} != *9999 ]]; then
PATCHES=(
- "${FILESDIR}/Remove-distro-version-test.patch"
+ "${FILESDIR}/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch"
+ "${FILESDIR}/pypugjs.patch"
)
fi
-pkg_setup() {
- enewuser buildbot
+distutils_enable_tests setup.py
+pkg_setup() {
DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
to support starting buildbot through Gentoo's init system. To use this,
execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
@@ -133,12 +144,6 @@ src_install() {
readme.gentoo_create_doc
}
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}
-
pkg_postinst() {
readme.gentoo_print_elog
diff --git a/dev-util/buildbot/files/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch b/dev-util/buildbot/files/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch
new file mode 100644
index 000000000000..16fc0a133e10
--- /dev/null
+++ b/dev-util/buildbot/files/Add-gentoo-to-the-VERSION_ID-check-exclusion.patch
@@ -0,0 +1,26 @@
+From f8d6fe39570a698d80d821a440219f5cd79d8314 Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Tue, 5 Mar 2019 11:21:14 -0800
+Subject: [PATCH] test_buildbot_net_usage.py: Add "gentoo" to the VERSION_ID check exclusion
+
+Make the exclusions test into a list (slight speed improvement, easier to extend) and add "gentoo".
+
+Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
+---
+ buildbot/test/unit/test_buildbot_net_usage_data.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/buildbot/test/unit/test_buildbot_net_usage_data.py b/buildbot/test/unit/test_buildbot_net_usage_data.py
+index c347956..e422c55 100644
+--- a/buildbot/test/unit/test_buildbot_net_usage_data.py
++++ b/buildbot/test/unit/test_buildbot_net_usage_data.py
+@@ -150,5 +150,5 @@ class Tests(unittest.TestCase):
+ self.assertEqual(len(distro), 2)
+ self.assertNotIn("unknown", distro[0])
+ # Rolling distributions like Arch Linux (arch) does not have VERSION_ID
+- if distro[0] != "arch":
++ if distro[0] not in ["arch", "gentoo"]:
+ self.assertNotIn("unknown", distro[1])
+--
+libgit2 0.99.0
+
diff --git a/dev-util/buildbot/files/pypugjs.patch b/dev-util/buildbot/files/pypugjs.patch
new file mode 100644
index 000000000000..3ac99502b5d5
--- /dev/null
+++ b/dev-util/buildbot/files/pypugjs.patch
@@ -0,0 +1,84 @@
+From 26fefa8f8fa7b347e1c86723194de3a4094dc012 Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Sat, 25 Apr 2020 11:53:06 -0700
+Subject: [PATCH] Initial pyjade port to pypugjs
+
+---
+ common/code_spelling_ignore_words.txt | 1 +
+ master/buildbot/test/unit/test_www_config.py | 8 ++++----
+ master/buildbot/www/config.py | 10 +++++-----
+ master/docs/manual/configuration/www.rst | 10 ++++++----
+ master/docs/spelling_wordlist.txt | 2 +-
+ master/setup.py | 4 ++--
+ requirements-ci.txt | 2 +-
+ 7 files changed, 20 insertions(+), 17 deletions(-)
+
+diff --git a/buildbot/test/unit/test_www_config.py b/buildbot/test/unit/test_www_config.py
+index 23a108e..a8c24ec 100644
+--- a/buildbot/test/unit/test_www_config.py
++++ b/buildbot/test/unit/test_www_config.py
+@@ -107,10 +107,10 @@ class IndexResource(TestReactorMixin, www.WwwTestMixin, unittest.TestCase):
+ def test_parseCustomTemplateDir(self):
+ exp = {'views/builds.html': '<div>\n</div>'}
+ try:
+- # we make the test work if pyjade is present or note
+- # It is better than just skip if pyjade is not there
+- import pyjade # pylint: disable=import-outside-toplevel
+- [pyjade]
++ # we make the test work if pypugjs is present or note
++ # It is better than just skip if pypugjs is not there
++ import pypugjs # pylint: disable=import-outside-toplevel
++ [pypugjs]
+ exp.update({'plugin/views/plugin.html':
+ '<div class="myclass"><pre>this is customized</pre></div>'})
+ except ImportError:
+diff --git a/buildbot/www/config.py b/buildbot/www/config.py
+index a021299..50bae4d 100644
+--- config.py 2020-02-27 13:34:10.000000000 -0800
++++ config2.py 2020-05-11 17:26:44.587026761 -0700
+@@ -61,12 +61,12 @@
+ res = {}
+ allowed_ext = [".html"]
+ try:
+- import pyjade # pylint: disable=import-outside-toplevel
++ import pypugjs # pylint: disable=import-outside-toplevel
+ allowed_ext.append(".jade")
+ except ImportError: # pragma: no cover
+- log.msg("pyjade not installed. Ignoring .jade files from %s" %
++ log.msg("pypugjs not installed. Ignoring .jade files from %s" %
+ (template_dir,))
+- pyjade = None
++ pypugjs = None
+ for root, dirs, files in os.walk(template_dir):
+ if root == template_dir:
+ template_name = posixpath.join("views", "%s.html")
+@@ -86,9 +86,9 @@
+ elif ext == ".jade":
+ with open(fn) as f:
+ jade = f.read()
+- parser = pyjade.parser.Parser(jade)
++ parser = pypugjs.parser.Parser(jade)
+ block = parser.parse()
+- compiler = pyjade.ext.html.Compiler(
++ compiler = pypugjs.ext.html.Compiler(
+ block, pretty=False)
+ html = compiler.compile()
+ res[template_name % (basename,)] = html
+diff --git a/setup.py b/master/setup.py
+index 8fca506..1f32a74 100755
+--- a/setup.py
++++ b/setup.py
+@@ -490,8 +490,8 @@ test_deps = [
+ # http client libraries
+ 'treq',
+ 'txrequests',
+- # pyjade required for custom templates tests
+- 'pyjade',
++ # pypugjs required for custom templates tests
++ 'pypugjs',
+ # boto3 and moto required for running EC2 tests
+ 'boto3',
+ 'moto',
+--
+libgit2 0.99.0
+
diff --git a/dev-util/buildbot/metadata.xml b/dev-util/buildbot/metadata.xml
index 16f4ac623ef9..45ebb49fa835 100644
--- a/dev-util/buildbot/metadata.xml
+++ b/dev-util/buildbot/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
<longdescription lang="en">
BuildBot is a system to automate the compile/test cycle required
by most software projects to validate code changes.