summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Strahl <c.a.strahl@gmail.com>2020-08-01 13:21:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-21 10:14:45 +0300
commit035867efe959afb1cd1bcb417a380c6da5fe4beb (patch)
treecc8be6f34ecdade7d07aad2d0051973a82595714 /dev-util/clion
parentdev-util/clion: version bump to 2020.2 (diff)
downloadgentoo-035867efe959afb1cd1bcb417a380c6da5fe4beb.tar.gz
gentoo-035867efe959afb1cd1bcb417a380c6da5fe4beb.tar.bz2
gentoo-035867efe959afb1cd1bcb417a380c6da5fe4beb.zip
dev-util/clion: remove old versions
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Christian Strahl <c.a.strahl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16927 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/clion')
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2020.1.2.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 47e0d06c77b0..36c77024458b 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1,2 +1 @@
-DIST clion-2020.1.2.tar.gz 509953307 BLAKE2B f4f3ed6478b8b17e7efa14932156da8087c71b850b2b08340b3d5fc9c39d84c547bd8d2ef194117609a6e9bcb85396796661ad70beb478a0579a85a25ec5d503 SHA512 68348a20a18f681298e0e1207c1794a437d58dd52d700ed7f3935e2434672b7648b0e6414b25e32fa3929a9c6973dd3024448dd514ffe05690826d02760fa4c3
DIST clion-2020.2.tar.gz 554215003 BLAKE2B 06ba16f3d2a3ebb4731e4ce40ec2ee56d3e823520d9b477a4ca7013391adb3e3c3e59b478810fa0ac9896e5277ec71642190e37be516990b0cbddd3178d2e245 SHA512 3b48a95a071919e3122e8bd8104202e07cf9cc9362df19f75003571771a134d4d5ec4520147c43b4fbd3144de8f67ddb904dbf88ef51714ec4d4882796b1272b
diff --git a/dev-util/clion/clion-2020.1.2.ebuild b/dev-util/clion/clion-2020.1.2.ebuild
deleted file mode 100644
index d50ca20ce175..000000000000
--- a/dev-util/clion/clion-2020.1.2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop eutils
-
-DESCRIPTION="A complete toolset for C and C++ development"
-HOMEPAGE="https://www.jetbrains.com/clion"
-SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( IDEA IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )
- Apache-1.1 Apache-2.0 BSD BSD-2 CC0-1.0 CDDL-1.1 CPL-0.5 CPL-1.0
- EPL-1.0 EPL-2.0 GPL-2 GPL-2-with-classpath-exception GPL-3 ISC JDOM
- LGPL-2.1+ LGPL-3 MIT MPL-1.0 MPL-1.1 OFL public-domain PSF-2 UoI-NCSA ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="bindist mirror splitdebug"
-IUSE="custom-jdk"
-
-# RDEPENDS may cause false positives in repoman.
-# clion requires cmake and gdb at runtime to build and debug C/C++ projects
-RDEPEND="
- dev-libs/libdbusmenu
- dev-util/cmake
- sys-devel/gdb
- !custom-jdk? ( virtual/jdk )"
-
-QA_PREBUILT="opt/${P}/*"
-
-src_prepare() {
- default
-
- local remove_me=(
- bin/gdb/linux
- bin/lldb/linux
- bin/cmake
- license/CMake*
- lib/pty4j-native/linux/ppc64le
- )
-
- use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
- use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
-
- use custom-jdk || remove_me+=( jbr )
-
- rm -rv "${remove_me[@]}" || die
-}
-
-src_install() {
- local dir="/opt/${P}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
-
- if use amd64; then
- fperms 755 "${dir}"/bin/fsnotifier64
- fi
- if use arm; then
- fperms 755 "${dir}"/bin/fsnotifier-arm
- fi
- if use x86; then
- fperms 755 "${dir}"/bin/fsnotifier
- fi
-
- if use custom-jdk; then
- if [[ -d jbr ]]; then
- fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
- fi
- fi
-
- make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
- newicon "bin/${PN}.svg" "${PN}.svg"
- make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- dodir /usr/lib/sysctl.d/
- echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
-}