summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-23 14:45:32 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-23 14:45:32 +0200
commit865bee46cd351962169d98e8f9d40bf164cf97d5 (patch)
treea32a7e795f50577f15b846580ca8768403580dcc /dev-util/dialog
parentdev-libs/libuv: Stable for HPPA too. (diff)
downloadgentoo-865bee46cd351962169d98e8f9d40bf164cf97d5.tar.gz
gentoo-865bee46cd351962169d98e8f9d40bf164cf97d5.tar.bz2
gentoo-865bee46cd351962169d98e8f9d40bf164cf97d5.zip
dev-util/dialog: Version 1.3.20180621.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/dialog')
-rw-r--r--dev-util/dialog/Manifest1
-rw-r--r--dev-util/dialog/dialog-1.3.20180621.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index f7c3ea7dfa50..327f78d56a71 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1,3 +1,4 @@
DIST dialog-1.3-20170131.tgz 507783 BLAKE2B a98c436eabc8d06619bd64a8b1d647a0712630f0f89565253636ef2f38333ca6926177aa0c2001305b0c06fc7a1f576cda87da493183402ef9ec3cdc3fa8be23 SHA512 818b4e9d0d5ee55377b78ccceacf59a78e5e6d6fbc09e24a19e62b4988ff8de32f3364132b9ee88c86e126114eda45c82d86397d5f26fae81a6bda91be979786
DIST dialog-1.3-20170509.tgz 509135 BLAKE2B 30f443953701f79db86a317d3c1a3a7743685388cf432a4d48e10f0df5181207e0a182f96566cd868d9ee5db8296f362e57f40a8e58c99d3b372eb967bc56ebe SHA512 dd3fe2041a15dd344ea39a1ba111d3b26daca1cda91a4e82f1223385a49cdf3de15f11129366a20c5a24b16b5301f215543850a390d70d0559f98247bbd49a56
+DIST dialog-1.3-20180621.tgz 529123 BLAKE2B bb085e93a0eaedd1fc517bcfe080f8dbf61bf0b28003b38356d66c324baed7dcd2f76917676a1894e76bf3a7d58d3090c95e45624dae37e3e2e885282ab9c5bb SHA512 1c6d794af50a12294e32b99fd9d3eb9451ac4a2f21c5567848b59c7a316b3058463c41fb8f9eb0bce68edbbe463234a6ec893f7a013ceb953eb5da0effe0d274
DIST dialog_1.3-20171209.orig.tar.gz 511503 BLAKE2B db633f882cce8a0ecd1446c26b305f5567bcdc0fb8e073ff3a443fbf56662638685578040ecd21220192c069899998f587aa04db8185074b4c8af957df77c49c SHA512 0355578bc64e2c75a2aae3ae83aff62eae60556a2890d50a72988efa76b82055755922bc1156a92370d773524865e76b8a0ddcde77fb6e6b5774c987fc22dee8
diff --git a/dev-util/dialog/dialog-1.3.20180621.ebuild b/dev-util/dialog/dialog-1.3.20180621.ebuild
new file mode 100644
index 000000000000..ffa55f6cd40c
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20180621.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib versionator
+
+DIA_P="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://dev.gentoo.org/~jer/${DIA_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples minimal nls static-libs unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2-r5:=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !minimal? ( sys-devel/libtool )
+ !<=sys-freebsd/freebsd-contrib-8.9999
+"
+S=${WORKDIR}/${DIA_P}
+
+src_prepare() {
+ default
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-rpath-hack \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts=$(usex static-libs '' '-shared') \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ prune_libtool_files
+}