summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-01 04:13:53 +0000
committerSam James <sam@gentoo.org>2022-01-01 04:13:53 +0000
commit98b7513838358b867656221830255403f7f5ea18 (patch)
tree1d4102d1c31a8ea5bc4007aba3a23daa91d265fb /dev-util/libtree
parentdev-util/diffoscope: drop 194, 195, 196 (diff)
downloadgentoo-98b7513838358b867656221830255403f7f5ea18.tar.gz
gentoo-98b7513838358b867656221830255403f7f5ea18.tar.bz2
gentoo-98b7513838358b867656221830255403f7f5ea18.zip
dev-util/libtree: add 3.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/libtree')
-rw-r--r--dev-util/libtree/Manifest1
-rw-r--r--dev-util/libtree/libtree-3.0.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/libtree/Manifest b/dev-util/libtree/Manifest
index 1d473a098c9c..3241204c94ce 100644
--- a/dev-util/libtree/Manifest
+++ b/dev-util/libtree/Manifest
@@ -1,2 +1,3 @@
DIST libtree-2.0.0.tar.gz 161133 BLAKE2B cf681f06fef9dfb44ad6099a4b7ab950cb23aef052a180cdd646498ac0baacf0f0caa14bac6a629d2bac2bd638d4b6e5ad97dd0d705e4d681021a168a6753b0f SHA512 9272afd8540110f43ade864a2df58d8b8a7690c79cd29a9804b43e7e550bc05a4da530a763a27bd85a474673055e7a5ba63c0aa0bcaf8b246fbfc73a4f36c870
DIST libtree-3.0.0.tar.gz 78989 BLAKE2B e930d2e88898337425906a285ad5fb318e9b36a0dd6bbdade528fcfad21aff3d460e619ff2f4a4534b0a7b1439a2dbe62b19626ee85d17fbe9a36a7ddaa63aad SHA512 d249e46c9f20ba51133ef9754a944f67383e5043a7e2a715d0937b3f22ff10cf96a69690b592a5118b3eed73a05b73bfb061d2f72583ad2bb9da969294f622ab
+DIST libtree-3.0.1.tar.gz 79050 BLAKE2B d1b14512fd29054c9625311841a86089a576f783233a181005d9b3454689f8a58c585f16fe26ad3e1d26ae4552149517989401a7f97e08265cf093ffc8aa5aa3 SHA512 92975fc2e77ca7e68ea22866e3a82836e9dcd69409f3fe0f61852c43b9aba6ceb67d1619afb27adc68ddb1615bd24621e3a8de8858b5ce84a9bd670830852ba1
diff --git a/dev-util/libtree/libtree-3.0.1.ebuild b/dev-util/libtree/libtree-3.0.1.ebuild
new file mode 100644
index 000000000000..ac802156d332
--- /dev/null
+++ b/dev-util/libtree/libtree-3.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="ldd as a tree with an option to bundle dependencies into a single folder"
+HOMEPAGE="https://github.com/haampie/libtree"
+SRC_URI="https://github.com/haampie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# 3.0.0 rewrote in C; tests don't seem to pass yet
+RESTRICT="test"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}