summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-10-07 16:54:51 -0700
committerZac Medico <zmedico@gentoo.org>2022-10-07 16:55:00 -0700
commite8883f974ed71fbc247a9c07b66cb5b11ecbb4d2 (patch)
treecdb0e6d7b4034c557f292d4555bd1f786359df81 /dev-util/ostree
parentdev-util/ostree: drop 2022.4, 2022.5 (diff)
downloadgentoo-e8883f974ed71fbc247a9c07b66cb5b11ecbb4d2.tar.gz
gentoo-e8883f974ed71fbc247a9c07b66cb5b11ecbb4d2.tar.bz2
gentoo-e8883f974ed71fbc247a9c07b66cb5b11ecbb4d2.zip
dev-util/ostree: add 2022.6
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/ostree')
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/ostree-2022.6.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index 5879886c1298..31dbc99bd3c0 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -1,3 +1,4 @@
DIST ostree-2021.3.tar.xz 2089804 BLAKE2B 5df33b676173b1ec08ac7592d4ddf8e3bfdcd84df1b3ce19e2f24c85780fed1f210b8adce1baf4ec87869c72984502276bf6e5a72268daaae6ce9b3d6dc6f88b SHA512 0df0d8f9bd82b16562dd5146997eddfb7cb6cffc1886601307d97a1cb1dc926bda7d0c899db26c974ed0dff1012dee11937e47c11c4d03307fa3d2d430adc60e
DIST ostree-2022.2.tar.xz 2059592 BLAKE2B 73bb563be473f3f62ab2d0e1ec6e2b659c8c12aaba828ae6fd5bab4b6bd3a978ffe5d76e17734e40c0569e3e74f13b85aaf9ae467747c5bbb309c73b373e9909 SHA512 07be16101aa00f541833dc6123f015ee1af65e40e2c237322a129e944fa19791e7cad6f0b29ced3c128adbe23bdb3c8708688fadd4ed80b160acab584b84abfe
DIST ostree-2022.5.tar.xz 2072208 BLAKE2B be12432c87da82362ceb49b61b0cfc2ab77fdd7e55dfd3ca238d3c0f6fa5e64dd953d709c39727a46f82b99ef07bfbebf83b581f5e96a10a08322854e9a0e1f9 SHA512 39abd076491ebab5cd6e23bff6ce0a346fe8d1e6a372abb42626ef5a8643411070b272637513b37393dc37af9b8eaaa42c19e2f1c16b98d441358c2046653654
+DIST ostree-2022.6.tar.xz 2124464 BLAKE2B c6ea1f11d08261e8532345ffc18bec9e77d04e63aab0c8e2eb03a4b3d3c2c594bcc9e6c5341e4caefe81fbd06a055cd39b0f2f2b43d3e876837a9bac43c704f5 SHA512 03f6b6947a372e36d3a1ae3bbe47543c562113039ce10db9c6f26a7b4015afb41950bd00bd1931937a5fb3043689ca1046eb87afd890571cfedbfa1ef36219a7
diff --git a/dev-util/ostree/ostree-2022.6.ebuild b/dev-util/ostree/ostree-2022.6.ebuild
new file mode 100644
index 000000000000..eb5a1bf3c90e
--- /dev/null
+++ b/dev-util/ostree/ostree-2022.6.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostreedev.github.io/ostree/"
+SRC_URI="https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="archive +curl doc dracut gnutls +gpg grub +http2 httpd introspection libmount selinux sodium ssl +soup systemd zeroconf"
+RESTRICT+=" test"
+REQUIRED_USE="
+ dracut? ( systemd )
+ http2? ( curl )
+ httpd? ( || ( curl soup ) )
+"
+
+COMMON_DEPEND="
+ app-arch/xz-utils
+ dev-libs/libassuan
+ dev-libs/glib:2
+ sys-fs/fuse:3
+ sys-libs/zlib
+ archive? ( app-arch/libarchive:= )
+ curl? ( net-misc/curl )
+ dracut? ( sys-kernel/dracut )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error
+ )
+ grub? ( sys-boot/grub:2= )
+ introspection? ( dev-libs/gobject-introspection )
+ libmount? ( sys-apps/util-linux )
+ selinux? ( sys-libs/libselinux )
+ sodium? ( >=dev-libs/libsodium-1.0.14:= )
+ soup? ( net-libs/libsoup:2.4 )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ zeroconf? ( net-dns/avahi[dbus] )"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ doc? ( dev-util/gtk-doc )"
+
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lib${P}"
+
+src_prepare() {
+ default
+
+ sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
+ -i Makefile.in Makefile-man.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --enable-man
+ --enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
+ $(use_with archive libarchive)
+ $(use_with curl)
+ $(use_with dracut dracut yesbutnoconf) #816867
+ $(use_enable doc gtk-doc)
+ $(usex introspection --enable-introspection={,} yes no)
+ $(use_with gpg gpgme)
+ $(use_enable http2)
+ $(use_enable httpd trivial-httpd-cmdline)
+ $(use_with selinux )
+ $(use_with soup)
+ $(use_with libmount)
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
+ $(use_with sodium ed25519-libsodium)
+ $(use_with systemd libsystemd)
+ $(use_with zeroconf avahi)
+ )
+
+ if use systemd; then
+ econfargs+=(--with-systemdsystemunitdir="$(systemd_get_systemunitdir)")
+ fi
+
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}