summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-07-05 16:14:53 +0200
committerMichael Weber <xmw@gentoo.org>2016-07-05 16:14:53 +0200
commit2e1885cc2fc82ef8e4ff7c9a5c70030795d297ef (patch)
treef26afd3340c59bcb95ad6b4985583d6447b6a882 /dev-util/pycharm-community
parentdev-util/pycharm-community: Drop old. (diff)
downloadgentoo-2e1885cc2fc82ef8e4ff7c9a5c70030795d297ef.tar.gz
gentoo-2e1885cc2fc82ef8e4ff7c9a5c70030795d297ef.tar.bz2
gentoo-2e1885cc2fc82ef8e4ff7c9a5c70030795d297ef.zip
dev-util/pycharm-community: Version bump (bug 584740), update to readme.gentoo-r1 (bug 582438).
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2016.1.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index a55859d3657e..766e36fd1177 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1 +1,2 @@
DIST pycharm-community-2016.1.3.tar.gz 207707566 SHA256 98c406abf20cbe18565dfe17a62ac7dba094ed15100aab566ff343eb726647cf SHA512 09327867d231b311616d76d860e27ed0c1ac20ca86eda0be9d58666993b860f3c562fa5ce7e533f898eccf7ad2c72954681c83095310bfe01c428a64c59a475e WHIRLPOOL eb03ad07a14707d0650b9991e0494e299336bb61722b6384fa1a2721cc8b692a031ac84f4cfdbd909a45bbacc6d2e1e3d6eec0e5c202a22133f953a402b38b6d
+DIST pycharm-community-2016.1.4.tar.gz 207346180 SHA256 bc548a200022111e741604e76b579e71e5a75d23c2bbb9c4cb9ed88b18a3d622 SHA512 f86726d921baec5a5f2691f7e9ee4f81d4abd3a55edc09f091593434d79a51e0058025eb52f1ca5455844d47d325e209f73d7e701d218db57bcf9502244201d6 WHIRLPOOL 9e51cb7f5c2e3530666831803c4bc0dfe8d36b58da0e593763028e9097f95e778098923f837a771c063fa1336cf3a58ba4ebe14cddbbec6f9c74921a1deedb9c
diff --git a/dev-util/pycharm-community/pycharm-community-2016.1.4.ebuild b/dev-util/pycharm-community/pycharm-community-2016.1.4.ebuild
new file mode 100644
index 000000000000..233c50990d3d
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2016.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+QA_PREBUILT="*"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_create_doc
+}