summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Lopatin <alopatindev@gmail.com>2023-12-13 19:48:46 +0800
committerJoonas Niilola <juippis@gentoo.org>2024-02-01 16:06:08 +0200
commit5bcf6a5c3b0a9aa25bdef30f1a060f4669afa385 (patch)
tree070976b8e4c02efcb29136ab8d513b1d2085ea59 /dev-util/qdevicemonitor
parentsys-process/anacron: add acct-group/cron BDEP (diff)
downloadgentoo-5bcf6a5c3b0a9aa25bdef30f1a060f4669afa385.tar.gz
gentoo-5bcf6a5c3b0a9aa25bdef30f1a060f4669afa385.tar.bz2
gentoo-5bcf6a5c3b0a9aa25bdef30f1a060f4669afa385.zip
dev-util/qdevicemonitor: disable pedantic errors
Closes: https://bugs.gentoo.org/919714 Signed-off-by: Alexander Lopatin <alopatindev@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34264 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/qdevicemonitor')
-rw-r--r--dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-disable-pedantic-errors.patch31
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild3
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-disable-pedantic-errors.patch b/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-disable-pedantic-errors.patch
new file mode 100644
index 000000000000..61e16be45360
--- /dev/null
+++ b/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-disable-pedantic-errors.patch
@@ -0,0 +1,31 @@
+From 5b2a6cbc4d64d5ee48d6fae1cf2a8f17335be634 Mon Sep 17 00:00:00 2001
+From: Alexander Lopatin <alopatindev@gmail.com>
+Date: Wed, 13 Dec 2023 19:16:54 +0800
+Subject: [PATCH] Disable pedantic errors
+
+https://bugs.gentoo.org/919714
+---
+ qdevicemonitor/qdevicemonitor.pro | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/qdevicemonitor/qdevicemonitor.pro b/qdevicemonitor/qdevicemonitor.pro
+index 6aa2ecf..5327af0 100644
+--- a/qdevicemonitor/qdevicemonitor.pro
++++ b/qdevicemonitor/qdevicemonitor.pro
+@@ -61,11 +61,11 @@ FORMS += \
+
+ CONFIG += c++11 link_pkgconfig
+
+-QMAKE_CXXFLAGS += -pedantic-errors -pedantic -Wextra -Wall
++QMAKE_CXXFLAGS += -Wextra -Wall
+ QMAKE_CXXFLAGS_RELEASE -= -O2
+ QMAKE_CXXFLAGS_RELEASE += -O3
+
+-QMAKE_CFLAGS += -pedantic-errors -pedantic -Wextra -Wall -std=c11
++QMAKE_CFLAGS += -Wextra -Wall -std=c11
+ QMAKE_CFLAGS_RELEASE -= -O2
+ QMAKE_CFLAGS_RELEASE += -O3
+
+--
+2.41.0
+
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
index 9fb33ff061a4..edf5f5dbf0ce 100644
--- a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
+++ b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,7 @@ PATCHES=(
"${FILESDIR}"/${P}-screen-geometry-is-deprecated.patch
"${FILESDIR}"/${P}-endl-is-deprecated.patch
"${FILESDIR}"/${P}-disable-warnings-as-errors.patch
+ "${FILESDIR}"/${P}-disable-pedantic-errors.patch
)
src_configure() {