summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/redet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/redet')
-rw-r--r--dev-util/redet/Manifest1
-rw-r--r--dev-util/redet/metadata.xml10
-rw-r--r--dev-util/redet/redet-8.26.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/redet/Manifest b/dev-util/redet/Manifest
new file mode 100644
index 000000000000..b874838a3fb2
--- /dev/null
+++ b/dev-util/redet/Manifest
@@ -0,0 +1 @@
+DIST redet-8.26.tar.gz 336661 SHA256 fa87d7b9fea0b380314cb9d62ce256128c75932822145bc8e6bef30703990746 SHA512 8400aaee58d5705cda6ce3ee1561f38d594adb18794fe4ecd9980278e2aa494ef559aa588cf7fb42937180ba1ddca1c6a69c124e71a5f44b2e21d2f44a6c9f0b WHIRLPOOL 2098361752c63b08edab7ede73aa072d0284a9e8cb375b8e7712a2ceac320473883a15ef38f281fa7da8df259c54521a21017bcaa32d56526302af94d2c690f8
diff --git a/dev-util/redet/metadata.xml b/dev-util/redet/metadata.xml
new file mode 100644
index 000000000000..f8ff719892e7
--- /dev/null
+++ b/dev-util/redet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A regular expression development and execution tool.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/redet/redet-8.26.ebuild b/dev-util/redet/redet-8.26.ebuild
new file mode 100644
index 000000000000..e9d65616f468
--- /dev/null
+++ b/dev-util/redet/redet-8.26.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A regular expression development and execution tool"
+HOMEPAGE="http://www.billposer.org/Software/redet.html"
+
+SRC_URI="http://www.billposer.org/Software/Downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-lang/tk
+ dev-tcltk/itk
+ dev-tcltk/iwidgets"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ local MANUAL_PN=`echo ${PN} | cut -c 1 | tr [:lower:] [:upper:]``echo ${PN} | cut -c 2-`
+
+ newbin ${PN}.tcl ${PN}
+
+ sed \
+ -e "/Encoding/d" \
+ -i ${PN}.desktop || die
+ domenu ${PN}.desktop
+
+ doman ${PN}.1 || die
+ dodoc AUTHORS CREDITS README-General README-MacOSX \
+ SampleClasses.utf8 \
+ SampleCustomCharacterWidgetDefinition_Armenian \
+ SampleCustomCharacterWidgetDefinition_Greek \
+ SampleNewStyleDotRedetRC_Elaborate SampleNewStyleDotRedetRC_Simple
+ dosym doc/${P}/html /usr/share/${MANUAL_PN}
+}