summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-05 07:59:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-05 09:15:01 +0200
commit744d739373bf6fda56819d354267f295019049a7 (patch)
tree89d07be86305a7e58b7e3bf2aaf3f33702fee169 /dev-util/sysdig-kmod
parentmedia-fonts/fira-code: add 3.1 (diff)
downloadgentoo-744d739373bf6fda56819d354267f295019049a7.tar.gz
gentoo-744d739373bf6fda56819d354267f295019049a7.tar.bz2
gentoo-744d739373bf6fda56819d354267f295019049a7.zip
dev-util/sysdig-kmod: Bump to 0.26.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/sysdig-kmod')
-rw-r--r--dev-util/sysdig-kmod/Manifest1
-rw-r--r--dev-util/sysdig-kmod/sysdig-kmod-0.26.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/sysdig-kmod/Manifest b/dev-util/sysdig-kmod/Manifest
index e1493303a0bd..e7e363175fd3 100644
--- a/dev-util/sysdig-kmod/Manifest
+++ b/dev-util/sysdig-kmod/Manifest
@@ -1 +1,2 @@
DIST sysdig-0.26.6.tar.gz 923918 BLAKE2B e022eba30977f5300c80a4806926d3e755b1395f05475c1fe925b86823670e397ad29e8bd18b1beaa893cb1bf83c329960c1bf9ff6faf0a5144343e88d52a4a0 SHA512 94784f0dfe46924b81d8804d950a9563cd18f4aa8b1cacd7e27e3974ecf7215223e03bdab001f408f64eb6c72f0da5082fd922d63079119427eb493c77e15795
+DIST sysdig-0.26.7.tar.gz 924647 BLAKE2B 31973410e8e166d82c3851eceee8bdcd808db8181e8330841ff746a2d2c35936fda9dcf23c16697e37da339a647b534b17d0c1bb58c547621f2a3f926fca5016 SHA512 37f3544b1994c8c9048c6ff886da0c2ea6cbfe0a1cedb930b2a06bb85fa9da80a8197409a99b95245dec9ca1957a0f1fe989f688a549739d71ff778087d20b76
diff --git a/dev-util/sysdig-kmod/sysdig-kmod-0.26.7.ebuild b/dev-util/sysdig-kmod/sysdig-kmod-0.26.7.ebuild
new file mode 100644
index 000000000000..ba7201399d5c
--- /dev/null
+++ b/dev-util/sysdig-kmod/sysdig-kmod-0.26.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-mod
+
+MY_P=${P/-kmod}
+DESCRIPTION="Kernel module for dev-util/sysdig"
+HOMEPAGE="https://sysdig.com/"
+SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( MIT GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="!<=dev-util/sysdig-0.26.4[modules]"
+
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e '/USE_BUNDLED_DEPS/,$d' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ )
+
+ cmake_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${BUILD_DIR}/driver/src:)"
+ BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
+ BUILD_TARGETS="all"
+}