summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-03 21:19:49 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-03 21:20:48 +0200
commit016d1a54468aaba50af2ab624440d65ac63589b6 (patch)
treee2f27b0008da03f80351e9984e3bebaa460cba5a /dev-util
parentapp-text/atril: add 1.26.1 (diff)
downloadgentoo-016d1a54468aaba50af2ab624440d65ac63589b6.tar.gz
gentoo-016d1a54468aaba50af2ab624440d65ac63589b6.tar.bz2
gentoo-016d1a54468aaba50af2ab624440d65ac63589b6.zip
dev-util/glade: Port to webkitgtk-4.1
Closes: https://bugs.gentoo.org/893690 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/glade/files/glade-3.40.0-webkitgtk-4.1.patch21
-rw-r--r--dev-util/glade/glade-3.40.0-r1.ebuild87
2 files changed, 108 insertions, 0 deletions
diff --git a/dev-util/glade/files/glade-3.40.0-webkitgtk-4.1.patch b/dev-util/glade/files/glade-3.40.0-webkitgtk-4.1.patch
new file mode 100644
index 000000000000..508c6ad85885
--- /dev/null
+++ b/dev-util/glade/files/glade-3.40.0-webkitgtk-4.1.patch
@@ -0,0 +1,21 @@
+From: Jeremy Bicha <jeremy.bicha@canonical.com>
+Date: Thu, 15 Sep 2022 08:04:05 -0400
+Subject: build: use webkitgtk 4.1
+
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 187555f..3f156e3 100644
+--- a/meson.build
++++ b/meson.build
+@@ -162,7 +162,7 @@ if have_python
+ endif
+
+ # WebKit2GTK support
+-webkit2gtk_dep = dependency('webkit2gtk-4.0', version: '>= 2.28.0', required: get_option('webkit2gtk'))
++webkit2gtk_dep = dependency('webkit2gtk-4.1', version: '>= 2.28.0', required: get_option('webkit2gtk'))
+ have_webkit2gtk = webkit2gtk_dep.found()
+
+ # Check for GDK Quartz and MacOSX integration package
diff --git a/dev-util/glade/glade-3.40.0-r1.ebuild b/dev-util/glade/glade-3.40.0-r1.ebuild
new file mode 100644
index 000000000000..c7f4c73ee9b0
--- /dev/null
+++ b/dev-util/glade/glade-3.40.0-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome2 python-single-r1 meson optfeature virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org https://gitlab.gnome.org/GNOME/glade"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/13" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="gjs gtk-doc +introspection python webkit"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.53.2:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ gjs? ( >=dev-libs/gjs-1.64.0 )
+ python? (
+ ${PYTHON_DEPS}
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+ ')
+ )
+ webkit? ( >=net-libs/webkit-gtk-2.12.0:4.1 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.2
+ )
+ dev-libs/libxslt
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="test" # https://gitlab.gnome.org/GNOME/glade/issues/333
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+ # https://gitlab.gnome.org/GNOME/glade/-/issues/555
+ "${FILESDIR}"/${PN}-3.40.0-webkitgtk-4.1.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgladeui=true
+ $(meson_feature gjs)
+ $(meson_feature python)
+ $(meson_feature webkit webkit2gtk)
+
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ optfeature_header
+ optfeature "integration API documentation support" dev-util/devhelp
+}