summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-10-07 13:19:56 +0100
committerMarek Szuba <marecki@gentoo.org>2019-10-07 13:22:53 +0100
commit36f31e3aa16cdd9f5544f8b9315fce0a657572e5 (patch)
tree77ec5a5aee877e24d6def5da2b76546cbd4c7345 /dev-util
parentdev-util/intel-graphics-compiler: remove old (diff)
downloadgentoo-36f31e3aa16cdd9f5544f8b9315fce0a657572e5.tar.gz
gentoo-36f31e3aa16cdd9f5544f8b9315fce0a657572e5.tar.bz2
gentoo-36f31e3aa16cdd9f5544f8b9315fce0a657572e5.zip
dev-util/intel-graphics-compiler: pass $LLVM_MAX_SLOT to get_llvm_prefix()
When invoked without max_slot, get_llvm_prefix() iterates over *all* LLVM slots known to llvm.eclass - including those exceeding LLVM_MAX_SLOT. As a consequence, an ebuild can e.g. end up getting installed into llvm:9 directories in spite of having been linked against llvm:8. Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
new file mode 100644
index 000000000000..c4d41e479ece
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -0,0 +1 @@
+DIST intel-graphics-compiler-1.0.11.tar.gz 5720630 BLAKE2B 1539de7aec3d0c357159a5be6c446ee4e3c98857fb666ab09ceefdb9ae93b430bc164de2f17848f25aeef1a95ce2066441aa0584354c14ed06fbb9179a17ba58 SHA512 2b4b43b152014329e2d9dcba1a5b832fb8c641a3bd004345ddc8d36a237bc15f112ef007894b5adbe175bf08584093adcee655b5e61a9da81d6956974e03248f
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11-r1.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..03d09a9af2dd
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ >=dev-libs/opencl-clang-8.0.1:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-no_Werror.patch
+)
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=8
+ )
+ cmake-utils_src_configure
+}