summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-10-22 10:57:48 -0700
committerMatt Turner <mattst88@gentoo.org>2020-10-22 10:58:49 -0700
commita4f52fce9b7808efed188061d38def995e899eee (patch)
tree1de88869ee0130c823793d838cd42bf16eaf9ba9 /dev-util
parentnet-fs/nfs-utils: Bump to version 2.5.2 (diff)
downloadgentoo-a4f52fce9b7808efed188061d38def995e899eee.tar.gz
gentoo-a4f52fce9b7808efed188061d38def995e899eee.tar.bz2
gentoo-a4f52fce9b7808efed188061d38def995e899eee.zip
dev-util/catalyst: Check for UTS_NS IPC_NS Kconfig options
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index aa0697220ebd..8b532c332b7b 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -15,7 +15,7 @@ fi
PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1 optfeature ${SRC_ECLASS}
+inherit distutils-r1 linux-info optfeature ${SRC_ECLASS}
DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
@@ -74,6 +74,11 @@ RDEPEND="
)
"
+pkg_setup() {
+ CONFIG_CHECK="~UTS_NS ~IPC_NS"
+ linux-info_pkg_setup
+}
+
python_prepare_all() {
python_setup
echo VERSION="${PV}" "${PYTHON}" setup.py set_version