summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2018-04-05 13:31:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-05 14:20:52 +0200
commitad36b2ad4ebe0aeca7b9e8deeb570e8a8fe167f4 (patch)
tree8ef5a927a414ae73a8b16b2e7aacfd47e47aa18a /dev-util
parentdev-util/spec-cleaner: Update to 1.0.6 (diff)
downloadgentoo-ad36b2ad4ebe0aeca7b9e8deeb570e8a8fe167f4.tar.gz
gentoo-ad36b2ad4ebe0aeca7b9e8deeb570e8a8fe167f4.tar.bz2
gentoo-ad36b2ad4ebe0aeca7b9e8deeb570e8a8fe167f4.zip
dev-util/spec-cleaner: EAPI-6 bump, drop python2_7 support
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/spec-cleaner/spec-cleaner-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
index 61a6579ab757..297d0528ae6b 100644
--- a/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
+++ b/dev-util/spec-cleaner/spec-cleaner-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{3_4,3_5} )
EGIT_REPO_URI="https://github.com/openSUSE/spec-cleaner.git"
inherit distutils-r1
[[ ${PV} == 9999 ]] && inherit git-r3
@@ -14,20 +14,25 @@ HOMEPAGE="https://github.com/openSUSE/spec-cleaner"
LICENSE="BSD"
SLOT="0"
-[[ ${PV} != 9999 ]] && \
+[[ ${PV} != 9999 ]] &&
KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)
"
RDEPEND="
${PYTHON_DEPS}
+ >=app-arch/rpm-4.11.0.1
"
+PATCHES=(
+ # pytest-runner is only needed in test scenario
+ "${FILESDIR}/${PN}-1.0.6-pytest-runner.patch"
+)
+
[[ ${PV} != 9999 ]] && S="${WORKDIR}/${PN}-${P}"
src_prepare() {
@@ -39,5 +44,5 @@ src_prepare() {
}
python_test() {
- nosetests
+ esetup.py test
}