summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-12-29 12:42:39 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2018-12-29 13:41:07 +0100
commit8c783094ba618f2f10ddaa6dc20304c5abc8a25e (patch)
treef0cd498fa22fd27884d49baace1d69766de20ee7 /dev-vcs/gitg
parentsys-apps/baobab: add missing vala_depend (diff)
downloadgentoo-8c783094ba618f2f10ddaa6dc20304c5abc8a25e.tar.gz
gentoo-8c783094ba618f2f10ddaa6dc20304c5abc8a25e.tar.bz2
gentoo-8c783094ba618f2f10ddaa6dc20304c5abc8a25e.zip
dev-vcs/gitg: misc build-time fixes
Drop gnome-common, build system is now meson and does not need this. Upgrade requirement on gettext due to use of meson. Add missing call to xdg_environment_reset. Make use of meson_use. Drop unneeded pkg_setup phase. These modifications only affect build so no bump. Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'dev-vcs/gitg')
-rw-r--r--dev-vcs/gitg/gitg-3.30.1.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-vcs/gitg/gitg-3.30.1.ebuild b/dev-vcs/gitg/gitg-3.30.1.ebuild
index 8b455c5215f3..338a545b1e50 100644
--- a/dev-vcs/gitg/gitg-3.30.1.ebuild
+++ b/dev-vcs/gitg/gitg-3.30.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -46,23 +46,19 @@ DEPEND="${RDEPEND}
$(vala_depend)
>=dev-libs/libgit2-glib-0.24.4[vala]
>=dev-util/intltool-0.40
- gnome-base/gnome-common
- >=sys-devel/gettext-0.17
+ >=sys-devel/gettext-0.19.7
virtual/pkgconfig
"
-pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
-}
-
src_prepare() {
default
vala_src_prepare
+ xdg_environment_reset
}
src_configure() {
local emesonargs=(
- -Dglade_catalog=$(usex glade true false)
+ $(meson_use glade glade_catalog)
# we install the module manually anyway
-Dpython=false
)