summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /eclass/makeedit.eclass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'eclass/makeedit.eclass')
-rw-r--r--eclass/makeedit.eclass37
1 files changed, 37 insertions, 0 deletions
diff --git a/eclass/makeedit.eclass b/eclass/makeedit.eclass
new file mode 100644
index 000000000000..dad378fb8c35
--- /dev/null
+++ b/eclass/makeedit.eclass
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# @ECLASS: makeedit.eclass
+# @AUTHOR:
+# Spider
+# @BLURB: An eclass to replace some flags in makefiles
+# @DESCRIPTION:
+#
+# @CODE
+# To use this eclass, do 2 things:
+# 1. append-flags "$MAKEEDIT_FLAGS". If you filter-flags, make sure to do
+# the append-flags afterward, otherwise you'll lose them.
+# 2. after running configure or econf, call edit_makefiles to remove
+# extraneous CFLAGS from your Makefiles.
+# @CODE
+#
+# This combination should reduce the RAM requirements of your build, and maybe
+# even speed it up a bit.
+
+
+MAKEEDIT_FLAGS="-Wno-return-type -w"
+
+# @FUNCTION: edit_makefiles
+# @DESCRIPTION:
+# Removes some flags in makefiles
+edit_makefiles() {
+ # We already add "-Wno-return-type -w" to compiler flags, so
+ # no need to replace "-Wall" and "-Wreturn-type" with them.
+ einfo "Parsing Makefiles ..."
+ find . \( -iname makefile -o -name \*.mk -o -name GNUmakefile \) -print0 | \
+ xargs -0 sed -i \
+ -e 's:-Wall::g' \
+ -e 's:-Wreturn-type::g' \
+ -e 's:-pedantic::g'
+}