summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-07-08 18:25:16 +0000
committerMichał Górny <mgorny@gentoo.org>2023-07-17 11:44:13 +0200
commit8f952fad8ad5152d7877944c537f469f25d0a7af (patch)
tree241020d00587b43f5d6776ad19a777eab1176267 /eclass/multibuild.eclass
parentdev-python/pyproject-api: Remove old (diff)
downloadgentoo-8f952fad8ad5152d7877944c537f469f25d0a7af.tar.gz
gentoo-8f952fad8ad5152d7877944c537f469f25d0a7af.tar.bz2
gentoo-8f952fad8ad5152d7877944c537f469f25d0a7af.zip
multibuild.eclass: Remove --reflink=auto from calls to cp
--reflink=auto has become the default behaviour in coreutils 9, and it is not compatible with BSD userland. Signed-off-by: Violet Purcell <vimproved@inventati.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/multibuild.eclass')
-rw-r--r--eclass/multibuild.eclass6
1 files changed, 2 insertions, 4 deletions
diff --git a/eclass/multibuild.eclass b/eclass/multibuild.eclass
index 33edb9312a86..d8a5862731bf 100644
--- a/eclass/multibuild.eclass
+++ b/eclass/multibuild.eclass
@@ -170,8 +170,7 @@ multibuild_copy_sources() {
_multibuild_create_source_copy() {
einfo "${MULTIBUILD_VARIANT}: copying to ${BUILD_DIR}"
- # enable reflinking if possible to make this faster
- cp -p -R --reflink=auto \
+ cp -p -R \
"${_MULTIBUILD_INITIAL_BUILD_DIR}" "${BUILD_DIR}" || die
}
@@ -190,8 +189,7 @@ multibuild_merge_root() {
local src=${1}
local dest=${2}
- # enable reflinking if possible to make this faster
- cp -a --reflink=auto "${src}"/. "${dest}"/ || die "${MULTIBUILD_VARIANT:-(unknown)}: merging image failed"
+ cp -a "${src}"/. "${dest}"/ || die "${MULTIBUILD_VARIANT:-(unknown)}: merging image failed"
rm -rf "${src}" || die
}