summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-18 12:40:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:46:16 +0200
commit48ac50b0e59489db7ea9f20ddc905a814fbe07b7 (patch)
tree21ceb5459240e0eacba2c43464e1406cb18f0f30 /eclass
parentsys-libs/gdbm: Bump to version 1.21 (diff)
downloadgentoo-48ac50b0e59489db7ea9f20ddc905a814fbe07b7.tar.gz
gentoo-48ac50b0e59489db7ea9f20ddc905a814fbe07b7.tar.bz2
gentoo-48ac50b0e59489db7ea9f20ddc905a814fbe07b7.zip
cmake.eclass: Support EAPI-8
Move supported EAPI check on top, EXPORT_FUNCTIONS below guard. Switch to using current working directory instead of ${S} when initializing ${CMAKE_USE_DIR} and ${BUILD_DIR}. Sort inherits. Raise baseline cmake version to 3.20.5. Bug: https://bugs.gentoo.org/704524 Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/cmake.eclass95
1 files changed, 62 insertions, 33 deletions
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index 4bd09459ea62..137dbc660178 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -9,7 +9,7 @@
# Maciej Mrozowski <reavertm@gentoo.org>
# (undisclosed contributors)
# Original author: Zephyrus (zephyrus@mirach.it)
-# @SUPPORTED_EAPIS: 7
+# @SUPPORTED_EAPIS: 7 8
# @BLURB: common ebuild functions for cmake-based packages
# @DESCRIPTION:
# The cmake eclass makes creating ebuilds for cmake-based packages much easier.
@@ -17,16 +17,25 @@
# out-of-source builds (default), in-source builds and an implementation of the
# well-known use_enable function for CMake.
+case ${EAPI} in
+ 7|8) ;;
+ *) die "${ECLASS}: EAPI=${EAPI:-0} is not supported" ;;
+esac
+
if [[ -z ${_CMAKE_ECLASS} ]]; then
_CMAKE_ECLASS=1
+inherit flag-o-matic multiprocessing ninja-utils toolchain-funcs xdg-utils
+
# @ECLASS-VARIABLE: BUILD_DIR
+# @DEFAULT_UNSET
# @DESCRIPTION:
# Build directory where all cmake processed files should be generated.
# For in-source build it's fixed to ${CMAKE_USE_DIR}.
# For out-of-source build it can be overridden, by default it uses
-# ${WORKDIR}/${P}_build.
-: ${BUILD_DIR:=${WORKDIR}/${P}_build}
+# ${CMAKE_USE_DIR}_build (in EAPI-7: ${WORKDIR}/${P}_build).
+[[ ${EAPI} == 7 ]] && : ${BUILD_DIR:=${WORKDIR}/${P}_build}
+# EAPI-8: set inside _cmake_check_build_dir
# @ECLASS-VARIABLE: CMAKE_BINARY
# @DESCRIPTION:
@@ -58,16 +67,16 @@ _CMAKE_ECLASS=1
# @ECLASS-VARIABLE: CMAKE_REMOVE_MODULES_LIST
# @DESCRIPTION:
-# Array of CMake modules that will be removed in $S during src_prepare,
-# in order to force packages to use the system version.
-# Set to "none" to disable removing modules entirely.
+# Array of CMake modules that will be removed in ${CMAKE_USE_DIR}
+# (in EAPI-7: ${S}) during src_prepare, in order to force packages to use the
+# system version. Set to empty to disable removing modules entirely.
: ${CMAKE_REMOVE_MODULES_LIST:=FindBLAS FindLAPACK}
# @ECLASS-VARIABLE: CMAKE_USE_DIR
# @DESCRIPTION:
# Sets the directory where we are working with cmake, for example when
# application uses autotools and only one plugin needs to be done by cmake.
-# By default it uses ${S}.
+# By default it uses current working directory (in EAPI-7: ${S}).
# @ECLASS-VARIABLE: CMAKE_VERBOSE
# @DESCRIPTION:
@@ -93,18 +102,9 @@ _CMAKE_ECLASS=1
# @USER_VARIABLE
# @DEFAULT_UNSET
# @DESCRIPTION:
-# After running cmake_src_prepare, sets ${S} to read-only. This is
-# a user flag and should under _no circumstances_ be set in the ebuild.
-# Helps in improving QA of build systems that write to source tree.
-
-case ${EAPI} in
- 7) ;;
- *) die "EAPI=${EAPI:-0} is not supported" ;;
-esac
-
-inherit toolchain-funcs ninja-utils flag-o-matic multiprocessing xdg-utils
-
-EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
+# After running cmake_src_prepare, sets ${CMAKE_USE_DIR} (in EAPI-7: ${S}) to
+# read-only. This is a user flag and should under _no circumstances_ be set in
+# the ebuild. Helps in improving QA of build systems that write to source tree.
[[ ${CMAKE_MIN_VERSION} ]] && die "CMAKE_MIN_VERSION is banned; if necessary, set BDEPEND=\">=dev-util/cmake-${CMAKE_MIN_VERSION}\" directly"
[[ ${CMAKE_BUILD_DIR} ]] && die "The ebuild must be migrated to BUILD_DIR"
@@ -127,7 +127,7 @@ case ${CMAKE_MAKEFILE_GENERATOR} in
esac
if [[ ${PN} != cmake ]]; then
- BDEPEND+=" dev-util/cmake"
+ BDEPEND+=" >=dev-util/cmake-3.20.5"
fi
# @FUNCTION: cmake_run_in
@@ -264,14 +264,22 @@ cmake-utils_useno() { _cmake_banned_func "" "$@" ; }
# @DESCRIPTION:
# Determine using IN or OUT source build
_cmake_check_build_dir() {
- : ${CMAKE_USE_DIR:=${S}}
+ if [[ ${EAPI} == 7 ]]; then
+ : ${CMAKE_USE_DIR:=${S}}
+ else
+ : ${CMAKE_USE_DIR:=${PWD}}
+ fi
if [[ -n ${CMAKE_IN_SOURCE_BUILD} ]]; then
# we build in source dir
BUILD_DIR="${CMAKE_USE_DIR}"
+ else
+ : ${BUILD_DIR:=${CMAKE_USE_DIR}_build}
fi
+ einfo "Source directory (CMAKE_USE_DIR): \"${CMAKE_USE_DIR}\""
+ einfo "Build directory (BUILD_DIR): \"${BUILD_DIR}\""
+
mkdir -p "${BUILD_DIR}" || die
- einfo "Working in BUILD_DIR: \"$BUILD_DIR\""
}
# @FUNCTION: _cmake_modify-cmakelists
@@ -320,12 +328,14 @@ _cmake_modify-cmakelists() {
cmake_src_prepare() {
debug-print-function ${FUNCNAME} "$@"
- # FIXME: workaround from cmake-utils; use current working directory instead, bug #704524
- # esp. test with 'special' pkgs like: app-arch/brotli, media-gfx/gmic, net-libs/quiche
- pushd "${S}" > /dev/null || die
+ if [[ ${EAPI} == 7 ]]; then
+ pushd "${S}" > /dev/null || die # workaround from cmake-utils
+ # in EAPI-8, we use current working directory instead, bug #704524
+ # esp. test with 'special' pkgs like: app-arch/brotli, media-gfx/gmic, net-libs/quiche
+ fi
+ _cmake_check_build_dir
default_src_prepare
- _cmake_check_build_dir
# check if CMakeLists.txt exist and if no then die
if [[ ! -e ${CMAKE_USE_DIR}/CMakeLists.txt ]] ; then
@@ -351,17 +361,28 @@ cmake_src_prepare() {
local name
for name in "${modules_list[@]}" ; do
- find "${S}" -name ${name}.cmake -exec rm -v {} + || die
+ if [[ ${EAPI} == 7 ]]; then
+ find "${S}" -name ${name}.cmake -exec rm -v {} + || die
+ else
+ find -name "${name}.cmake" -exec rm -v {} + || die
+ fi
done
# Remove dangerous things.
_cmake_modify-cmakelists
- popd > /dev/null || die
+ if [[ ${EAPI} == 7 ]]; then
+ popd > /dev/null || die
+ fi
- # make ${S} read-only in order to detect broken build-systems
+ # Make ${CMAKE_USE_DIR} (in EAPI-7: ${S}) read-only in order to detect
+ # broken build systems.
if [[ ${CMAKE_QA_SRC_DIR_READONLY} && ! ${CMAKE_IN_SOURCE_BUILD} ]]; then
- chmod -R a-w "${S}"
+ if [[ ${EAPI} == 7 ]]; then
+ chmod -R a-w "${S}"
+ else
+ chmod -R a-w "${CMAKE_USE_DIR}"
+ fi
fi
_CMAKE_SRC_PREPARE_HAS_RUN=1
@@ -657,9 +678,17 @@ cmake_src_install() {
die "died running ${CMAKE_MAKEFILE_GENERATOR} install"
popd > /dev/null || die
- pushd "${S}" > /dev/null || die
- einstalldocs
- popd > /dev/null || die
+ if [[ ${EAPI} == 7 ]]; then
+ pushd "${S}" > /dev/null || die
+ einstalldocs
+ popd > /dev/null || die
+ else
+ pushd "${CMAKE_USE_DIR}" > /dev/null || die
+ einstalldocs
+ popd > /dev/null || die
+ fi
}
fi
+
+EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install