summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-03-04 16:52:39 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-03-04 17:06:15 +0000
commitb3e186940705ca1a3f9073fe8c3f09d541d6faba (patch)
tree0c89242835724060f2c2e824c431110f7425a06c /eclass
parentnet-proxy/squid-3.5.27-r1: alpha stable (diff)
downloadgentoo-b3e186940705ca1a3f9073fe8c3f09d541d6faba.tar.gz
gentoo-b3e186940705ca1a3f9073fe8c3f09d541d6faba.tar.bz2
gentoo-b3e186940705ca1a3f9073fe8c3f09d541d6faba.zip
makeedit.eclass: delete unused eclass
Closes: https://bugs.gentoo.org/637784 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/makeedit.eclass36
1 files changed, 0 insertions, 36 deletions
diff --git a/eclass/makeedit.eclass b/eclass/makeedit.eclass
deleted file mode 100644
index fb40cf781912..000000000000
--- a/eclass/makeedit.eclass
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# @ECLASS: makeedit.eclass
-# @AUTHOR:
-# Spider
-# @BLURB: An eclass to replace some flags in makefiles
-# @DESCRIPTION:
-#
-# @CODE
-# To use this eclass, do 2 things:
-# 1. append-flags "$MAKEEDIT_FLAGS". If you filter-flags, make sure to do
-# the append-flags afterward, otherwise you'll lose them.
-# 2. after running configure or econf, call edit_makefiles to remove
-# extraneous CFLAGS from your Makefiles.
-# @CODE
-#
-# This combination should reduce the RAM requirements of your build, and maybe
-# even speed it up a bit.
-
-
-MAKEEDIT_FLAGS="-Wno-return-type -w"
-
-# @FUNCTION: edit_makefiles
-# @DESCRIPTION:
-# Removes some flags in makefiles
-edit_makefiles() {
- # We already add "-Wno-return-type -w" to compiler flags, so
- # no need to replace "-Wall" and "-Wreturn-type" with them.
- einfo "Parsing Makefiles ..."
- find . \( -iname makefile -o -name \*.mk -o -name GNUmakefile \) -print0 | \
- xargs -0 sed -i \
- -e 's:-Wall::g' \
- -e 's:-Wreturn-type::g' \
- -e 's:-pedantic::g'
-}