summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 23:09:49 +0000
committerSam James <sam@gentoo.org>2021-04-06 23:09:49 +0000
commit60fd187648e58bf67ed58b889cef6ecbcdcc06a3 (patch)
treedd71081637202c0e333d22e3f19837e235e66432 /games-action/descent3
parentgames-action/heretic2-demo: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-60fd187648e58bf67ed58b889cef6ecbcdcc06a3.tar.gz
gentoo-60fd187648e58bf67ed58b889cef6ecbcdcc06a3.tar.bz2
gentoo-60fd187648e58bf67ed58b889cef6ecbcdcc06a3.zip
games-action/descent3: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action/descent3')
-rw-r--r--games-action/descent3/descent3-1.4.0b-r3.ebuild (renamed from games-action/descent3/descent3-1.4.0b-r2.ebuild)36
1 files changed, 19 insertions, 17 deletions
diff --git a/games-action/descent3/descent3-1.4.0b-r2.ebuild b/games-action/descent3/descent3-1.4.0b-r3.ebuild
index 44a13d1b0af9..0756a6d15fc4 100644
--- a/games-action/descent3/descent3-1.4.0b-r2.ebuild
+++ b/games-action/descent3/descent3-1.4.0b-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils unpacker cdrom multilib games
+EAPI=7
+
+inherit cdrom desktop unpacker wrapper
-IUSE="nocd videos"
DESCRIPTION="Descent 3 - 3-Dimensional indoor/outdoor spaceship combat"
HOMEPAGE="http://www.lokigames.com/products/descent3/"
SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
@@ -13,20 +13,23 @@ SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
LICENSE="LOKI-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="nocd videos"
+
RESTRICT="strip mirror bindist"
-RDEPEND="sys-libs/glibc
+RDEPEND="
media-libs/libsdl[abi_x86_32(-)]
media-libs/smpeg[abi_x86_32(-)]
+ sys-libs/glibc
virtual/opengl[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]"
+ x11-libs/libXext[abi_x86_32(-)]
+"
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
+dir=opt/${PN}
+Ddir="${ED}"/${dir}
pkg_setup() {
- games_pkg_setup
if use videos ; then
ewarn "The installed game takes about 1.2GB of space!"
elif use nocd ; then
@@ -42,6 +45,7 @@ src_unpack() {
else
cdrom_get_cds missions/d3.mn3
fi
+
mkdir -p "${S}"/{a,b} || die
cd "${S}"/a || die
unpack_makeself ${PN}-1.4.0a-x86.run
@@ -51,9 +55,9 @@ src_unpack() {
src_install() {
einfo "Copying files... this may take a while..."
- exeinto "${dir}"
+ exeinto ${dir}
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{${PN},nettest}
- insinto "${dir}"
+ insinto ${dir}
doins ${CDROM_ROOT}/{FAQ.txt,README{,.mercenary},d3.hog,icon.{bmp,xpm}}
cd "${Ddir}" || die
@@ -73,6 +77,7 @@ src_install() {
cd "${S}"/a || die
bin/Linux/x86/loki_patch --verify patch.dat || die
bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
+
cd "${S}"/b || die
bin/Linux/x86/loki_patch --verify patch.dat || die
bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
@@ -80,22 +85,19 @@ src_install() {
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find "${Ddir}" -exec touch '{}' +
+ find "${Ddir}" -exec touch '{}' + || die
- games_make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
+ make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
# Fix for 2.6 kernel crash
cd "${Ddir}" || die
- ln -sf ppics.hog PPics.Hog
+ ln -sf ppics.hog PPics.Hog || die
- prepgamesdirs
make_desktop_entry ${PN} "Descent 3" ${PN}
}
pkg_postinst() {
- games_pkg_postinst
elog "To play the game run:"
elog " descent3"
- echo
}