summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 20:15:51 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 20:35:48 -0500
commit4385c470211466d5683ac9aa87ff44cbf54d33ba (patch)
tree074c5b61447c246bc23acf604751fe61959a9090 /games-action
parentapp-text/a2ps: Stabilize 4.14-r8 ppc64, #882325 (diff)
downloadgentoo-4385c470211466d5683ac9aa87ff44cbf54d33ba.tar.gz
gentoo-4385c470211466d5683ac9aa87ff44cbf54d33ba.tar.bz2
gentoo-4385c470211466d5683ac9aa87ff44cbf54d33ba.zip
games-action/battalion: fix build w/ upcoming clang16
Also add missing xorg-proto dep while here. Closes: https://bugs.gentoo.org/874987 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/battalion/battalion-1.4b-r2.ebuild7
-rw-r--r--games-action/battalion/files/battalion-1.4b-clang16.patch8
2 files changed, 13 insertions, 2 deletions
diff --git a/games-action/battalion/battalion-1.4b-r2.ebuild b/games-action/battalion/battalion-1.4b-r2.ebuild
index cf5a5613754a..db2d3d24992f 100644
--- a/games-action/battalion/battalion-1.4b-r2.ebuild
+++ b/games-action/battalion/battalion-1.4b-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,12 +21,15 @@ RDEPEND="
virtual/glu
virtual/opengl
x11-libs/libX11"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-warning.patch
"${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {
diff --git a/games-action/battalion/files/battalion-1.4b-clang16.patch b/games-action/battalion/files/battalion-1.4b-clang16.patch
new file mode 100644
index 000000000000..866e6227de05
--- /dev/null
+++ b/games-action/battalion/files/battalion-1.4b-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/874987
+--- a/battalion.c
++++ b/battalion.c
+@@ -5471,3 +5471,3 @@
+
+-main (int argc, char*argv[])
++int main (int argc, char*argv[])
+ {