summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-30 13:50:47 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-30 17:09:07 -0600
commit5e18087a7390cc3dbe626867a1ff2b8dbe78038b (patch)
tree957947e62da7e7df4616225e83b39a327da2ead9 /games-action
parentros-meta/image_common: Bump to 1.11.12. (diff)
downloadgentoo-5e18087a7390cc3dbe626867a1ff2b8dbe78038b.tar.gz
gentoo-5e18087a7390cc3dbe626867a1ff2b8dbe78038b.tar.bz2
gentoo-5e18087a7390cc3dbe626867a1ff2b8dbe78038b.zip
games-action/snipes: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/snipes/files/snipes-1.0.4-nongnulinker.patch4
-rw-r--r--games-action/snipes/snipes-1.0.4-r1.ebuild35
2 files changed, 37 insertions, 2 deletions
diff --git a/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch b/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
index dbfab286e4b0..8bdaeef3e356 100644
--- a/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
+++ b/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2011-12-18 17:24:28.795315064 +0100
-+++ Makefile 2011-12-18 17:24:59.005311478 +0100
+--- a/Makefile 2011-12-18 17:24:28.795315064 +0100
++++ b/Makefile 2011-12-18 17:24:59.005311478 +0100
@@ -33,7 +33,7 @@
IMGOBJ = $(OIMGS:%.pbm=$(INTERMEDIATE)/%.o)
diff --git a/games-action/snipes/snipes-1.0.4-r1.ebuild b/games-action/snipes/snipes-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..c2c89839357a
--- /dev/null
+++ b/games-action/snipes/snipes-1.0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs eutils
+
+DESCRIPTION="2D scrolling shooter, resembles the old DOS game of same name"
+HOMEPAGE="https://cyp.github.com/snipes/"
+SRC_URI="https://cyp.github.com/snipes/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-nongnulinker.patch
+)
+
+src_compile() {
+ tc-getLD
+ default
+}
+
+src_install() {
+ dobin snipes
+ doman snipes.6
+ dodoc ChangeLog
+ doicon ${PN}.png
+ make_desktop_entry snipes "Snipes"
+}