diff options
author | Pacho Ramos <pacho@gentoo.org> | 2018-04-15 10:59:33 +0200 |
---|---|---|
committer | Pacho Ramos <pacho@gentoo.org> | 2018-04-15 11:11:23 +0200 |
commit | dc9b81e1766fb34331fc7064a75574268d8358ec (patch) | |
tree | b75eeec3e05d01f6d6a456f593cba1e78e81635a /games-arcade/apricots | |
parent | games-arcade/aop: Drop old (diff) | |
download | gentoo-dc9b81e1766fb34331fc7064a75574268d8358ec.tar.gz gentoo-dc9b81e1766fb34331fc7064a75574268d8358ec.tar.bz2 gentoo-dc9b81e1766fb34331fc7064a75574268d8358ec.zip |
games-arcade/apricots: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/apricots')
-rw-r--r-- | games-arcade/apricots/apricots-0.2.6-r2.ebuild | 63 | ||||
-rw-r--r-- | games-arcade/apricots/files/apricots-0.2.6-freealut.patch | 12 | ||||
-rw-r--r-- | games-arcade/apricots/files/apricots-0.2.6-ldflags.patch | 4 |
3 files changed, 71 insertions, 8 deletions
diff --git a/games-arcade/apricots/apricots-0.2.6-r2.ebuild b/games-arcade/apricots/apricots-0.2.6-r2.ebuild new file mode 100644 index 000000000000..b0a37bd7912b --- /dev/null +++ b/games-arcade/apricots/apricots-0.2.6-r2.ebuild @@ -0,0 +1,63 @@ +# Copyright 1999-2018 Gentoo Foundation +# Distributed under the terms of the GNU General Public License v2 + +EAPI=6 +inherit autotools desktop + +DESCRIPTION="Fly a plane around bomb/shoot the enemy. Port of Planegame from Amiga" +HOMEPAGE="http://www.fishies.org.uk/apricots.html" +SRC_URI="http://www.fishies.org.uk/${P}.tar.gz" + +LICENSE="GPL-2" +SLOT="0" +KEYWORDS="~amd64 ~x86 ~x86-fbsd" +IUSE="" + +DEPEND="media-libs/libsdl[sound,video] + media-libs/openal + media-libs/freealut" +RDEPEND="${DEPEND}" + +src_prepare() { + default + + eapply "${FILESDIR}"/${P}-freealut.patch \ + "${FILESDIR}"/${P}-ldflags.patch + + cp admin/acinclude.m4.in acinclude.m4 + + sed -i \ + -e 's:-DAP_PATH=\\\\\\"$prefix.*":-DAP_PATH=\\\\\\"/usr/share/${PN}/\\\\\\"":' \ + -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \ + configure.in || die + sed -i \ + -e "s:filename(AP_PATH):filename(\"/etc/${PN}/\"):" \ + ${PN}/init.cpp || die + sed -i \ + -e "s:apricots.cfg:/etc/${PN}/apricots.cfg:" \ + README apricots.html || die + sed -i \ + -e 's/-Wmissing-prototypes//' \ + acinclude.m4 || die + + mv configure.in configure.ac || die + eautoreconf +} + +src_compile() { + emake LIBTOOL="/usr/bin/libtool" +} + +src_install() { + HTML_DOCS="apricots.html" + einstalldocs + + cd ${PN} + dobin apricots + insinto /usr/share/${PN} + doins *.wav *.psf *.shapes + insinto /etc/${PN} + doins apricots.cfg + + make_desktop_entry ${PN} Apricots +} diff --git a/games-arcade/apricots/files/apricots-0.2.6-freealut.patch b/games-arcade/apricots/files/apricots-0.2.6-freealut.patch index 4f663071340a..d2e1b27f6f34 100644 --- a/games-arcade/apricots/files/apricots-0.2.6-freealut.patch +++ b/games-arcade/apricots/files/apricots-0.2.6-freealut.patch @@ -1,5 +1,5 @@ ---- apricots/apricots.cpp -+++ apricots/apricots.cpp +--- a/apricots/apricots.cpp ++++ b/apricots/apricots.cpp @@ -16,6 +16,7 @@ int main(int, char**){
#endif
@@ -9,8 +9,8 @@ gamedata g;
init_data(g);
---- apricots/sampleio.cpp -+++ apricots/sampleio.cpp +--- a/apricots/sampleio.cpp ++++ b/apricots/sampleio.cpp @@ -74,12 +74,9 @@ alListenerfv(AL_ORIENTATION, front );
@@ -51,8 +51,8 @@ }
---- configure.in -+++ configure.in +--- a/configure.in ++++ b/configure.in @@ -100,7 +100,8 @@ dnl Check for OpenAL diff --git a/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch index 5a2a34490b7e..8a7b4a9f9a8c 100644 --- a/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch +++ b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch @@ -1,5 +1,5 @@ ---- apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200 -+++ apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200 +--- a/apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200 ++++ b/apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200 @@ -4,7 +4,8 @@ ## INCLUDES were found outside kdevelop specific part |