summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/holotz-castle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/holotz-castle')
-rw-r--r--games-arcade/holotz-castle/Manifest1
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch71
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch11
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch11
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild52
-rw-r--r--games-arcade/holotz-castle/metadata.xml5
6 files changed, 151 insertions, 0 deletions
diff --git a/games-arcade/holotz-castle/Manifest b/games-arcade/holotz-castle/Manifest
new file mode 100644
index 000000000000..c168de9106e7
--- /dev/null
+++ b/games-arcade/holotz-castle/Manifest
@@ -0,0 +1 @@
+DIST holotz-castle-1.3.14-src.tar.gz 3691364 SHA256 42903559a9821b39eac6eba7730be0fcba12c9ad861ba2691f372c54371039b1
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
new file mode 100644
index 000000000000..bb834656601d
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
@@ -0,0 +1,71 @@
+--- JLib/Makefile
++++ JLib/Makefile
+@@ -19,7 +19,7 @@
+ endif
+
+ # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
+-CFLAGS=-I. -I/usr/local/include/SDL -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
++CXXFLAGS+=-I. -Wall -Wshadow `$(SDL_CONFIG) --cflags`
+
+ # Sample LDFLAGS for applications
+ # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+@@ -28,15 +28,14 @@
+
+ # JLib
+ libJLib: $(JLIB_OBJS)
+- g++-4.1 -shared -L/usr/lib -fPIC -o $@.so $? \
+- && ar rvus $@.a $? \
++ $(AR) rvus $@.a $?
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+ .PHONY: install
+ install:
+--- src/Makefile
++++ src/Makefile
+@@ -30,7 +30,7 @@
+
+ DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
+
+-all: JLib HC HCed
++all: HC HCed
+
+ HC_OBJ_MAIN=HolotzCastle.o
+ HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
+@@ -42,23 +42,23 @@
+
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -I/usr/local/include/ -I/usr/local/include/SDL -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c
+-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++CXXFLAGS+=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -Wall -Wshadow
++LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+
+
+ JLib:
+ $(MAKE) -C ../JLib;
+
+ %.o: %.cpp %.h
+- g++ $(CFLAGS) $(DEFINES) $< -o $@
++ $(CXX) -c $(CXXFLAGS) $(DEFINES) $< -o $@
+
+ HC: $(HC_OBJS) $(HC_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $? $(LDLIBS);\
+ mv HC ../holotz-castle
+
+ # HCed (Holotz's Castle editor).
+ HCed: $(HC_OBJS) $(HCED_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $? $(LDLIBS);\
+ mv HCed ../holotz-castle-editor
+
+ install:
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
new file mode 100644
index 000000000000..0c3af53591bf
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
@@ -0,0 +1,11 @@
+--- JLib/JLib/Util/JFS.cpp
++++ JLib/JLib/Util/JFS.cpp
+@@ -887,7 +887,7 @@
+
+ // Si es un directorio lo importa recursivamente
+ struct dirent64 **namelist;
+- n = scandir64(filename, &namelist, 0, alphasort);
++ n = scandir64(filename, &namelist, 0, alphasort64);
+
+ if (n < 0)
+ {
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
new file mode 100644
index 000000000000..2e23b2a40995
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.old 2011-06-22 06:09:53.195025702 +0200
++++ src/Makefile 2011-06-22 06:10:54.774927134 +0200
+@@ -43,7 +43,7 @@
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+ CXXFLAGS+=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -Wall -Wshadow
+-LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs` -lm -lz
+
+
+ JLib:
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
new file mode 100644
index 000000000000..2f747c7d07a5
--- /dev/null
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="2D platform game"
+HOMEPAGE="http://www.mainreactor.net/holotzcastle/en/index_en.html"
+SRC_URI="http://www.mainreactor.net/holotzcastle/download/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-image"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_compile() {
+ tc-export AR
+ emake -C JLib
+ emake -C src HC_BASE="${GAMES_DATADIR}"/${PN}/
+}
+
+src_install() {
+ dogamesbin holotz-castle holotz-castle-editor
+ insinto "${GAMES_DATADIR}"/${PN}/game
+ doins -r res/*
+ insinto "${GAMES_DATADIR}"/${PN}/editor
+ doins -r HCedHome/res/*
+ newicon res/icon/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Holotz's Castle" /usr/share/pixmaps/${PN}.bmp
+ make_desktop_entry ${PN}-editor "Holotz's Castle - Editor" \
+ /usr/share/pixmaps/${PN}.bmp
+ dodoc doc/MANUAL*.txt
+ doman man/*.6
+ prepgamesdirs
+}
diff --git a/games-arcade/holotz-castle/metadata.xml b/games-arcade/holotz-castle/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/holotz-castle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>