summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/tuxdash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/tuxdash')
-rw-r--r--games-arcade/tuxdash/Manifest1
-rw-r--r--games-arcade/tuxdash/files/tuxdash-0.8-ldflags.patch8
-rw-r--r--games-arcade/tuxdash/metadata.xml5
-rw-r--r--games-arcade/tuxdash/tuxdash-0.8.ebuild51
4 files changed, 65 insertions, 0 deletions
diff --git a/games-arcade/tuxdash/Manifest b/games-arcade/tuxdash/Manifest
new file mode 100644
index 000000000000..56b1ff5505d8
--- /dev/null
+++ b/games-arcade/tuxdash/Manifest
@@ -0,0 +1 @@
+DIST tuxdash_src_0.8.tar.bz2 447560 SHA256 6d29dbd5fba3c72e86d2ab2c036b24577d4eee1761467ac13924a43f2bcdbc02 SHA512 5c42b89ce3121025801d78d35962a2aa3d10e4443f6c929e7df4b45673e6285f37ed353877aa33eaa0edf584f7a428a8f485301ba1476865a498ab699ee81f86 WHIRLPOOL 1351f99690710124691a0ce1bc29c61bc29a78e07e7204c8c04de1775c73888aeb44b764471eb2b396ae305f45bbb6ca490c59afc7ed646c39f6fb3d4a08ba0b
diff --git a/games-arcade/tuxdash/files/tuxdash-0.8-ldflags.patch b/games-arcade/tuxdash/files/tuxdash-0.8-ldflags.patch
new file mode 100644
index 000000000000..00d2afb55307
--- /dev/null
+++ b/games-arcade/tuxdash/files/tuxdash-0.8-ldflags.patch
@@ -0,0 +1,8 @@
+--- src/Makefile.old 2010-09-30 06:24:36.000000000 +0200
++++ src/Makefile 2010-09-30 06:25:02.000000000 +0200
+@@ -1,4 +1,4 @@
+ all:
+- g++ main.cpp $(E_CXXFLAGS) `/usr/bin/sdl-config --libs --cflags` -lSDL_ttf -o ../tuxdash
++ $(CXX) main.cpp $(LDFLAGS) $(E_CXXFLAGS) `/usr/bin/sdl-config --libs --cflags` -lSDL_ttf -o ../tuxdash
+ static:
+ g++ -static main.cpp $(E_CXXFLAGS) `/usr/bin/sdl-config --cflags --static-libs` -lSDL_ttf -lfreetype -lz -o ../tuxdash
diff --git a/games-arcade/tuxdash/metadata.xml b/games-arcade/tuxdash/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/tuxdash/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/tuxdash/tuxdash-0.8.ebuild b/games-arcade/tuxdash/tuxdash-0.8.ebuild
new file mode 100644
index 000000000000..cf7d4c125899
--- /dev/null
+++ b/games-arcade/tuxdash/tuxdash-0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A simple BoulderDash clone"
+HOMEPAGE="http://www.tuxdash.de/index.php?language=EN"
+SRC_URI="http://www.tuxdash.de/ressources/downloads/${PN}_src_${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -f GPL TuxDash
+ sed -i \
+ -e '/^Fullscreen/ s/0/1/' \
+ -e "/^theme/ s:themes:${GAMES_DATADIR}/${PN}/themes:" \
+ config || die "sed failed"
+ sed -i \
+ -e '/PWD/d' \
+ -e '/CurrentDirectory;/d' \
+ -e "s:CurrentDirectory:\"${GAMES_DATADIR}/${PN}\":" \
+ src/main.cpp || die "sed failed"
+ sed -i \
+ -e 's/-Wall/$(E_CXXFLAGS)/' \
+ -e 's/TuxDash/tuxdash/g' \
+ src/Makefile || die "sed failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ find . -type f -print0 | xargs -0 chmod a-x
+}
+
+src_compile() {
+ emake E_CXXFLAGS="${CXXFLAGS}" -C src
+}
+
+src_install() {
+ dogamesbin tuxdash
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r themes maps fonts savegames config "${D}/${GAMES_DATADIR}/${PN}" \
+ || die "cp failed"
+ dodoc README*
+ prepgamesdirs
+}