summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/blokish
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/blokish')
-rw-r--r--games-board/blokish/Manifest1
-rw-r--r--games-board/blokish/blokish-0.9.4-r1.ebuild44
-rw-r--r--games-board/blokish/files/blokish-0.9.4-gcc43.patch12
-rw-r--r--games-board/blokish/files/blokish-0.9.4-underlink.patch9
-rw-r--r--games-board/blokish/metadata.xml8
5 files changed, 74 insertions, 0 deletions
diff --git a/games-board/blokish/Manifest b/games-board/blokish/Manifest
new file mode 100644
index 000000000000..b4d4c2cf9145
--- /dev/null
+++ b/games-board/blokish/Manifest
@@ -0,0 +1 @@
+DIST blokish_v0.9.4.tgz 165215 SHA256 9ce9f6bf747df73b7827c37d4ecb24e10bdf491380bc8f9df3e32f45252bd54d SHA512 f84e5c31999cfca4bc6504907a889561c0e6c986b6c7bbd0d7325cec248d7e5d7834d841326635a605669b7bffd9fdb8c8fe73a216a738dace0385ae8a98cbec WHIRLPOOL e059adc2fbdffe8c9c4635d23cff73ae84f6733ce7f10d1c33de534ecad5a90e390e6b9884a1806dc634dbd7303bc57e646b155223b2d51ca3baa0f76803a3bc
diff --git a/games-board/blokish/blokish-0.9.4-r1.ebuild b/games-board/blokish/blokish-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..c3a3dd85c1ac
--- /dev/null
+++ b/games-board/blokish/blokish-0.9.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="2.8"
+inherit eutils autotools wxwidgets games
+
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Open source clone of the four-player board game Blokus"
+HOMEPAGE="http://sourceforge.net/projects/blokish/"
+SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:2.8[X,opengl]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+ sed -i \
+ -e "s:wx-config:${WX_CONFIG}:" \
+ configure.in makefile.am || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} Blokish ${PN}
+
+ dohtml docs/*
+ prepgamesdirs
+}
diff --git a/games-board/blokish/files/blokish-0.9.4-gcc43.patch b/games-board/blokish/files/blokish-0.9.4-gcc43.patch
new file mode 100644
index 000000000000..3e48bce774d6
--- /dev/null
+++ b/games-board/blokish/files/blokish-0.9.4-gcc43.patch
@@ -0,0 +1,12 @@
+--- src/base.h
++++ src/base.h
+@@ -25,6 +25,9 @@
+ #include <vector>
+ #include <fstream>
+ #include <iostream>
++#include <algorithm>
++#include <cstdlib>
++#include <climits>
+
+ enum BlokishID
+ {
diff --git a/games-board/blokish/files/blokish-0.9.4-underlink.patch b/games-board/blokish/files/blokish-0.9.4-underlink.patch
new file mode 100644
index 000000000000..9a9eb6eab5a4
--- /dev/null
+++ b/games-board/blokish/files/blokish-0.9.4-underlink.patch
@@ -0,0 +1,9 @@
+--- makefile.am.old 2011-06-21 08:43:21.804880067 +0200
++++ makefile.am 2011-06-21 08:43:49.875661081 +0200
+@@ -1,5 +1,5 @@
+ INCLUDES = `wx-config --cxxflags`
+-LIBS = `wx-config --libs --gl-libs`
++LIBS = `wx-config --libs --gl-libs` -lGL -lm
+
+ bin_PROGRAMS = blokish
+
diff --git a/games-board/blokish/metadata.xml b/games-board/blokish/metadata.xml
new file mode 100644
index 000000000000..99e24ee1d027
--- /dev/null
+++ b/games-board/blokish/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">blokish</remote-id>
+ </upstream>
+</pkgmetadata>