summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 18:48:24 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-14 12:26:33 -0500
commitcfcc1265854507cd6a0311cdeb8dfd6959a1b153 (patch)
treef1d01a794017c0b90cfe3510b76e5a638c1f2074 /games-board/chessx
parentgames-board/cgoban2: remove deprecated games eclass (diff)
downloadgentoo-cfcc1265854507cd6a0311cdeb8dfd6959a1b153.tar.gz
gentoo-cfcc1265854507cd6a0311cdeb8dfd6959a1b153.tar.bz2
gentoo-cfcc1265854507cd6a0311cdeb8dfd6959a1b153.zip
games-board/chessx: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/chessx')
-rw-r--r--games-board/chessx/chessx-1.4.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/chessx/chessx-1.4.0-r1.ebuild b/games-board/chessx/chessx-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..5c34a6352d99
--- /dev/null
+++ b/games-board/chessx/chessx-1.4.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils qmake-utils
+
+DESCRIPTION="Qt5-based Chess Database Utility"
+HOMEPAGE="http://chessx.sourceforge.net/"
+SRC_URI="https://sourceforge.net/projects/chessx/files/chessx/${PV}/${P}.tgz"
+
+LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-zlib.patch
+)
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dobin release/${PN}
+ dodoc ChangeLog TODO
+ doicon data/images/${PN}.png
+ domenu unix/chessx.desktop
+}