summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-21 17:22:07 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-21 17:59:43 -0400
commita9f7ffbdc8a02179d7a93ab6d7311692a03a236c (patch)
tree7ecc172123b9647ba84ea9dacbb9455a49b68b61 /games-board/four-in-a-row
parentgames-arcade/gnome-robots: Version bump to 40.0 (diff)
downloadgentoo-a9f7ffbdc8a02179d7a93ab6d7311692a03a236c.tar.gz
gentoo-a9f7ffbdc8a02179d7a93ab6d7311692a03a236c.tar.bz2
gentoo-a9f7ffbdc8a02179d7a93ab6d7311692a03a236c.zip
games-board/four-in-a-row: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board/four-in-a-row')
-rw-r--r--games-board/four-in-a-row/Manifest1
-rw-r--r--games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-board/four-in-a-row/Manifest b/games-board/four-in-a-row/Manifest
index e4031ba87326..f2f9dc813f07 100644
--- a/games-board/four-in-a-row/Manifest
+++ b/games-board/four-in-a-row/Manifest
@@ -1 +1,2 @@
DIST four-in-a-row-3.36.4.tar.xz 558244 BLAKE2B 63a61de3150fe067faebffc021f78398a267b0788e5353d6953dbf6b6836a21901f9bb8f498872a083b1d8c9ccd9dfe2a58c529e2655959084a64102f2ac4d3b SHA512 5f73f2b2548c9b9dfdf1310cdb22c65e7f96135367d55e113b1c779ed21aab5ed01eaaa009c346035a222fa8c87c6224334d546407963a90f068b5ca8ae1b58d
+DIST four-in-a-row-3.38.1.tar.xz 565408 BLAKE2B ac7991404707d1dff5a1819d7844da799e47c185eacc265312af06065b89f3ab787582c5a718de0342894a61c617a809f874a2a7b67e7f6f106862147c6b4feb SHA512 f30dd912e0dc9f4b59706de96b216428c7fd2deac5686cfe1e4e8be9923862bf767b7533d29aa59cf3e631c7a13e5b9d2fcfc18fc20559778fd0102cc32b5835
diff --git a/games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild b/games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild
new file mode 100644
index 000000000000..d862dd8a2b1f
--- /dev/null
+++ b/games-board/four-in-a-row/four-in-a-row-3.38.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Make lines of the same color to win"
+HOMEPAGE="https://wiki.gnome.org/Apps/Four-in-a-row https://gitlab.gnome.org/GNOME/four-in-a-row"
+
+# Code and most themes are GPL-3+, CC-BY-SA-3.0 is user help license in v3.32.0
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}