summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/simsu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/simsu')
-rw-r--r--games-board/simsu/Manifest1
-rw-r--r--games-board/simsu/files/simsu-1.2.3-langs.patch11
-rw-r--r--games-board/simsu/metadata.xml5
-rw-r--r--games-board/simsu/simsu-1.2.3.ebuild52
4 files changed, 69 insertions, 0 deletions
diff --git a/games-board/simsu/Manifest b/games-board/simsu/Manifest
new file mode 100644
index 000000000000..ac39f94e7f47
--- /dev/null
+++ b/games-board/simsu/Manifest
@@ -0,0 +1 @@
+DIST simsu-1.2.3-src.tar.bz2 328020 SHA256 623a27e487bd360bee58430b6530f3371f915a868910615572559a3e055a5da4 SHA512 52e19c9f7de5d8d2d2c986cbcaefa61a21ee1d8eca8a8315e9689034e9d4a9e63db02cb163daa7354a368d8e34789c1f623f0482ad9fbb52fdb447cce7505b44 WHIRLPOOL daf5e28fd35b884a751a4df9485a70538fb29813bfcf00203057c0a67291139145795866af5ddd70fa307e7dd511a5f69b1f201df48ce6c118b5bd6b434018b3
diff --git a/games-board/simsu/files/simsu-1.2.3-langs.patch b/games-board/simsu/files/simsu-1.2.3-langs.patch
new file mode 100644
index 000000000000..118c33bea499
--- /dev/null
+++ b/games-board/simsu/files/simsu-1.2.3-langs.patch
@@ -0,0 +1,11 @@
+diff -ru simsu-1.2.3.orig/src/locale_dialog.cpp simsu-1.2.3/src/locale_dialog.cpp
+--- simsu-1.2.3.orig/src/locale_dialog.cpp 2013-02-14 13:17:54.000000000 -0500
++++ simsu-1.2.3/src/locale_dialog.cpp 2013-09-09 16:00:09.449992139 -0400
+@@ -85,6 +85,7 @@
+ if (paths.isEmpty()) {
+ QString appdir = QCoreApplication::applicationDirPath();
+ paths.append(appdir);
++ paths.append("GENTOODATADIR");
+ paths.append(appdir + "/../share/" + QCoreApplication::applicationName().toLower());
+ paths.append(appdir + "/../Resources");
+ }
diff --git a/games-board/simsu/metadata.xml b/games-board/simsu/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/simsu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/simsu/simsu-1.2.3.ebuild b/games-board/simsu/simsu-1.2.3.ebuild
new file mode 100644
index 000000000000..3a2e5e0085e7
--- /dev/null
+++ b/games-board/simsu/simsu-1.2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils qt4-r2 games
+
+DESCRIPTION="A basic sudoku game"
+HOMEPAGE="http://gottcode.org/simsu/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-langs.patch
+
+ sed -i \
+ -e "s:GENTOODATADIR:${GAMES_DATADIR}/${PN}:" \
+ src/locale_dialog.cpp || die
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}/translations
+ doins translations/*qm
+ dodoc ChangeLog
+ doicon -s scalable icons/hicolor/scalable/apps/${PN}.svg
+ domenu icons/${PN}.desktop
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}