summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-04-21 01:48:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-04-21 01:58:29 -0400
commit28a18e46865836f0f7ff7d1951625c74c97076c3 (patch)
treea280558b36f293daf2693644b2eadd8f6e553d4c /games-emulation
parentwww-client/qutebrowser: stabilize 2.5.0 for amd64 (diff)
downloadgentoo-28a18e46865836f0f7ff7d1951625c74c97076c3.tar.gz
gentoo-28a18e46865836f0f7ff7d1951625c74c97076c3.tar.bz2
gentoo-28a18e46865836f0f7ff7d1951625c74c97076c3.zip
games-emulation/pcsx2: update live, unbundle libzip[zstd]
It uses libzip for savestates and enables zstd when doing so. Also adjust comments and explicitly disable QT_BUILD, mostly as a reminder to do later when Qt6 is in the tree. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index bdd694c0a1c5..8c462bcb79c6 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -30,6 +30,7 @@ RDEPEND="
dev-libs/libchdr
>=dev-libs/libfmt-7.1.3:=
dev-libs/libxml2:2
+ dev-libs/libzip:=[zstd]
media-libs/alsa-lib
media-libs/cubeb
media-libs/freetype
@@ -73,8 +74,11 @@ src_prepare() {
cmake_src_prepare
# unbundle, use sed over patch for less chances to break -9999
+ # (zstd is only used by libzip, so can remove entirely)
sed -e '/add_subdir.*cubeb/c\find_package(cubeb REQUIRED)' \
-e '/add_subdir.*libchdr/c\pkg_check_modules(chdr REQUIRED IMPORTED_TARGET libchdr)' \
+ -e '/add_subdir.*libzip/c\find_package(libzip REQUIRED)' \
+ -e '/add_subdir.*zstd/d' \
-e '/compile_options(\(cubeb\|chdr-static\|speex\)/d' \
-i cmake/SearchForStuff.cmake || die
sed -i 's/chdr-static/PkgConfig::chdr/' pcsx2/CMakeLists.txt || die
@@ -99,7 +103,8 @@ src_configure() {
-DDISABLE_SETCAP=TRUE
-DENABLE_TESTS=$(usex test)
-DPACKAGE_MODE=TRUE
- -DSDL2_API=TRUE # uses SDL2 either way but option is needed if wxGTK[sdl]
+ -DQT_BUILD=FALSE # TODO
+ -DSDL2_API=TRUE # conditionally needed if wxGTK[sdl], cmake/ApiValidation.cmake
-DUSE_SYSTEM_YAML=TRUE
-DUSE_VTUNE=FALSE
-DXDG_STD=TRUE