summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-27 19:52:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-27 20:08:40 -0400
commit59ff79ab1c87e63d8b6a6b5d9828f4bc48b56ec2 (patch)
treea061bd38d90408836d0ef009364a7367e0991803 /games-engines/openmw
parentapp-admin/ansible-lint: drop 6.3.0 (diff)
downloadgentoo-59ff79ab1c87e63d8b6a6b5d9828f4bc48b56ec2.tar.gz
gentoo-59ff79ab1c87e63d8b6a6b5d9828f4bc48b56ec2.tar.bz2
gentoo-59ff79ab1c87e63d8b6a6b5d9828f4bc48b56ec2.zip
games-engines/openmw: fix build with gcc12
Seeing users hit this, so fixing myself quick. Builds but not thoroughly tested so there could be other issues. Closes: https://bugs.gentoo.org/858725 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-engines/openmw')
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-gcc12.patch33
-rw-r--r--games-engines/openmw/openmw-0.47.0-r1.ebuild3
2 files changed, 35 insertions, 1 deletions
diff --git a/games-engines/openmw/files/openmw-0.47.0-gcc12.patch b/games-engines/openmw/files/openmw-0.47.0-gcc12.patch
new file mode 100644
index 000000000000..4c04d7b25c78
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.47.0-gcc12.patch
@@ -0,0 +1,33 @@
+Backport missing includes causing issues with gcc12.
+https://bugs.gentoo.org/858725
+https://gitlab.com/OpenMW/openmw/-/commit/5f2e282359
+From: elsid <elsid.mail@gmail.com>
+Date: Tue, 17 May 2022 00:58:24 +0200
+Subject: [PATCH] Add includes for used types and functions
+--- a/components/myguiplatform/myguidatamanager.cpp
++++ b/components/myguiplatform/myguidatamanager.cpp
+@@ -1,8 +1,11 @@
+ #include "myguidatamanager.hpp"
+
++#include <memory>
++#include <string>
++
+ #include <MyGUI_DataFileStream.h>
+
+-#include <boost/filesystem.hpp>
++#include <boost/filesystem/operations.hpp>
+ #include <boost/filesystem/fstream.hpp>
+
+ #include <components/debug/debuglog.hpp>
+--- a/components/myguiplatform/myguidatamanager.hpp
++++ b/components/myguiplatform/myguidatamanager.hpp
+@@ -3,6 +3,8 @@
+
+ #include <MyGUI_DataManager.h>
+
++#include <string>
++
+ namespace osgMyGUI
+ {
+
+GitLab
diff --git a/games-engines/openmw/openmw-0.47.0-r1.ebuild b/games-engines/openmw/openmw-0.47.0-r1.ebuild
index 7dd2a4a0a958..0d9ccae64cb6 100644
--- a/games-engines/openmw/openmw-0.47.0-r1.ebuild
+++ b/games-engines/openmw/openmw-0.47.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -64,6 +64,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/openmw-0.47.0-mygui-license.patch
"${FILESDIR}"/openmw-0.47.0-sigstksz.patch
+ "${FILESDIR}"/openmw-0.47.0-gcc12.patch
)
src_prepare() {