summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-09-10 19:33:09 +0900
committerJames Le Cuirot <chewi@gentoo.org>2019-09-19 23:08:31 +0100
commitcc51ed57d5b277bf9d2df5af62df28265839357b (patch)
tree5f58e0cb64681bb9a6a98aeb7b86bb9d7f82099e /games-fps/gzdoom
parentprofiles: Last-rite games-action/minetest_game (diff)
downloadgentoo-cc51ed57d5b277bf9d2df5af62df28265839357b.tar.gz
gentoo-cc51ed57d5b277bf9d2df5af62df28265839357b.tar.bz2
gentoo-cc51ed57d5b277bf9d2df5af62df28265839357b.zip
games-fps/gzdoom: Bump to version 4.2.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12895 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps/gzdoom')
-rw-r--r--games-fps/gzdoom/Manifest1
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch36
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch34
-rw-r--r--games-fps/gzdoom/gzdoom-4.2.1.ebuild82
4 files changed, 153 insertions, 0 deletions
diff --git a/games-fps/gzdoom/Manifest b/games-fps/gzdoom/Manifest
index 1a1880d95654..6ea2bde6cef0 100644
--- a/games-fps/gzdoom/Manifest
+++ b/games-fps/gzdoom/Manifest
@@ -1 +1,2 @@
DIST gzdoom-4.2.0.tar.gz 13482879 BLAKE2B 5c68718b840ce00a752179b4c735f064ed2ea669eff5e4bd71e3ccea3bb9af238287ddffc297cbfbe6069c658ec1d203b73790c973f836f8aa9ba33ac3ec2803 SHA512 07ad674eb22eb1388a5e3a6bd91d769fef90cb52728034e30d2967c484acaa41cfc7fc9ed486f4dbd0e86ea4d32bbafde402b771fc2fceb0708551328ef08f0d
+DIST gzdoom-4.2.1.tar.gz 13660636 BLAKE2B f1399014441d1556cc16e8d89b8c321a0591996fbcf8ad85a99403faef3b4663636b2bc4543982f2fc9ebdba777e88e4685985390d2e798eb01c0cea683305f6 SHA512 37a21bf101442cbe36574666dfb92b28eeee6b4dc982d43a8d5c95255e1f49e2451740b54e100b59120cef67f68f6eb07f687155bbab712854ce7ddc7c0b6c4a
diff --git a/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch b/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
new file mode 100644
index 000000000000..c74d08a24a47
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.2.1-Introduce-the-BUILD_NONFREE-option.patch
@@ -0,0 +1,36 @@
+From 1e09b211a000c649aae6eea736647daa650141bc Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Sat, 31 Aug 2019 21:23:23 +0900
+Subject: [PATCH] Introduce the BUILD_NONFREE option
+
+This allow users to disable building nonfree components (brightmaps.pk3
+and game_support.pk3) if they so desire.
+---
+ CMakeLists.txt | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7860358ef..23d317f42 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -404,10 +404,15 @@ add_subdirectory( libraries/lzma )
+ add_subdirectory( tools )
+ add_subdirectory( libraries/dumb )
+ add_subdirectory( libraries/gdtoa )
++
+ add_subdirectory( wadsrc )
+-add_subdirectory( wadsrc_bm )
+ add_subdirectory( wadsrc_lights )
+-add_subdirectory( wadsrc_extra )
++option (BUILD_NONFREE "Build nonfree components" ON)
++if( BUILD_NONFREE )
++ add_subdirectory( wadsrc_bm )
++ add_subdirectory( wadsrc_extra )
++endif()
++
+ add_subdirectory( src )
+
+ if( NOT CMAKE_CROSSCOMPILING )
+--
+2.23.0
+
diff --git a/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch b/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
new file mode 100644
index 000000000000..1fe0b99d9a8e
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.2.1-install_soundfonts.patch
@@ -0,0 +1,34 @@
+From 2d1c7ba17cac3ccd201e77ad01a9dd06ab22cb2e Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Thu, 13 Jun 2019 18:01:08 +0900
+Subject: [PATCH] Install soundfonts and WOPL/WOPN banks
+
+The INSTALL_SOUNDFONT_PATH cache entry is used to configure the
+installation directory.
+---
+ src/CMakeLists.txt | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0bb16f39e..4ff15062d 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1451,6 +1451,15 @@ add_custom_command(TARGET zdoom POST_BUILD
+ ${CMAKE_SOURCE_DIR}/fm_banks/gs-by-papiezak-and-sneakernets.wopn $<TARGET_FILE_DIR:zdoom>/fm_banks/gs-by-papiezak-and-sneakernets.wopn
+ )
+
++if( WIN32 )
++ set( INSTALL_SOUNDFONT_PATH . CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++else()
++ set( INSTALL_SOUNDFONT_PATH share/games/doom CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++endif()
++install(FILES "${PROJECT_BINARY_DIR}/soundfonts" "${PROJECT_BINARY_DIR}/fm_banks"
++ DESTINATION ${INSTALL_SOUNDFONT_PATH}
++ COMPONENT "Soundfont resources")
++
+ if( CMAKE_COMPILER_IS_GNUCXX )
+ # GCC misoptimizes this file
+ set_source_files_properties( oplsynth/fmopl.cpp PROPERTIES COMPILE_FLAGS "-fno-tree-dominator-opts -fno-tree-fre" )
+--
+2.21.0
+
diff --git a/games-fps/gzdoom/gzdoom-4.2.1.ebuild b/games-fps/gzdoom/gzdoom-4.2.1.ebuild
new file mode 100644
index 000000000000..baca2173701c
--- /dev/null
+++ b/games-fps/gzdoom/gzdoom-4.2.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop xdg
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT
+ nonfree? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gtk gtk2 +nonfree openmp"
+
+DEPEND="
+ media-libs/libsdl2[opengl]
+ media-libs/libsndfile
+ media-libs/openal
+ media-sound/fluidsynth:=
+ media-sound/mpg123
+ sys-libs/zlib
+ virtual/jpeg:0
+ gtk? (
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-g${PV}"
+PATCHES=(
+ "${FILESDIR}/${P}-install_soundfonts.patch"
+ "${FILESDIR}/${P}-Introduce-the-BUILD_NONFREE-option.patch"
+)
+
+src_prepare() {
+ rm -rf docs/licenses || die
+ if ! use nonfree ; then
+ rm -rf wadsrc_bm wadsrc_extra || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
+ -DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
+ -DINSTALL_SOUNDFONT_PATH="${EPREFIX}/usr/share/doom"
+ -DDYN_FLUIDSYNTH=OFF
+ -DDYN_OPENAL=OFF
+ -DDYN_SNDFILE=OFF
+ -DDYN_MPG123=OFF
+ -DNO_GTK="$(usex !gtk)"
+ -DNO_OPENAL=OFF
+ -DNO_OPENMP="$(usex !openmp)"
+ -DBUILD_NONFREE="$(usex nonfree)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newicon src/posix/zdoom.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use nonfree ; then
+ ewarn
+ ewarn "GZDoom installed without nonfree components."
+ ewarn "Note: The nonfree game_support.pk3 file is needed to play"
+ ewarn " games natively supported by GZDoom."
+ ewarn "A list of games natively supported by GZDoom may be found"
+ ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"
+ ewarn
+ fi
+}