summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <william.gray@linaro.org>2022-12-02 11:43:19 -0500
committerJames Le Cuirot <chewi@gentoo.org>2022-12-08 21:59:08 +0000
commit5b68f6835d7b3e29b9037cd4bf631e2c13bbf1b4 (patch)
tree70255d8e9361a3338b318650f66dc8546ce7a7dd /games-fps
parentgames-util/joycond: Bump snapshot to 20220720. drop old 20210730 (diff)
downloadgentoo-5b68f6835d7b3e29b9037cd4bf631e2c13bbf1b4.tar.gz
gentoo-5b68f6835d7b3e29b9037cd4bf631e2c13bbf1b4.tar.bz2
gentoo-5b68f6835d7b3e29b9037cd4bf631e2c13bbf1b4.zip
games-fps/gzdoom: version bump to 4.10.0
The 'swr' USE flag is introduced to configure support for the software renderer. This is mainly to allow users to disable the software renderer for new games that have been designed for hardware rendering. Closes: https://bugs.gentoo.org/884037 Signed-off-by: William Breathitt Gray <william.gray@linaro.org> Closes: https://github.com/gentoo/gentoo/pull/28511 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/gzdoom/Manifest1
-rw-r--r--games-fps/gzdoom/gzdoom-4.10.0.ebuild89
-rw-r--r--games-fps/gzdoom/metadata.xml1
3 files changed, 91 insertions, 0 deletions
diff --git a/games-fps/gzdoom/Manifest b/games-fps/gzdoom/Manifest
index 3fad5682d972..1d6e0cc12cac 100644
--- a/games-fps/gzdoom/Manifest
+++ b/games-fps/gzdoom/Manifest
@@ -1,2 +1,3 @@
+DIST gzdoom-4.10.0.tar.gz 24319337 BLAKE2B a683182ed1bb091d19cff127352068faa846f0a10bc0ade07f8277dca7a5367d0bc19d2828c485fba11cefdb47aa8d99224bb8babbebe3df0b99a6fde577a586 SHA512 fd2f6e34aaa59e3d153de6359211082398878dae3d396ab55fc736f94e1378d5e03193d7912a29a531cf1dc255d30af63ad1c6472784e3745db6ac4a3a9e6fe6
DIST gzdoom-4.7.1.tar.gz 19562412 BLAKE2B 48b089c9d0ca0f26820ea90ea1a1a6ce3fa325f6f7bd36ded66ba43eeaab610ca99eacb1ca0aec75b0888a65108573e2c85d2ce0e88663031583267f1143386e SHA512 040a51d2783616cca9f3d7e70bf83adf0d6afa8d7378a9f743cbf152811c07c4f03eecdbbdb617d9fda625049a6f13313dce6e5017698bf36fae74e107c012f0
DIST gzdoom-4.8.2.tar.gz 24247668 BLAKE2B b9a505c29d14486bec96f53f614968c67ec0d8db0b784071d171038dec3a88c800483211e4ba59e8408ce5680f4800cbc455b4a53becd53e89bde17c7b7a69a5 SHA512 5f94aca016e87c8284b41d5c3beaeb752a4201e4562a528375addc976c7d7163d23a4885a223e4377856a2b75b71179efa80e99baf3edfe87fa19cf1e8bbfa42
diff --git a/games-fps/gzdoom/gzdoom-4.10.0.ebuild b/games-fps/gzdoom/gzdoom-4.10.0.ebuild
new file mode 100644
index 000000000000..a9545cb61896
--- /dev/null
+++ b/games-fps/gzdoom/gzdoom-4.10.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg flag-o-matic
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BZIP2 GPL-3 LGPL-2.1+ LGPL-3 MIT
+ non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist WidePix )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="debug gles2 gtk +non-free openmp +swr telemetry vulkan"
+
+DEPEND="
+ app-arch/bzip2
+ media-libs/libjpeg-turbo:0=
+ media-libs/libsdl2[gles2?,opengl,vulkan?]
+ media-libs/libvpx:=
+ media-libs/openal
+ media-libs/zmusic
+ sys-libs/zlib
+ gtk? ( x11-libs/gtk+:3 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-g${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.1-Introduce-the-BUILD_NONFREE-option.patch
+)
+
+src_prepare() {
+ rm -rf docs/licenses || die
+ rm -rf libraries/{bzip2,jpeg,zlib} || die
+ if ! use non-free ; then
+ rm -rf wadsrc_bm wadsrc_extra wadsrc_widepix || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://bugs.gentoo.org/858749
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
+ -DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
+ -DINSTALL_SOUNDFONT_PATH="${EPREFIX}/usr/share/doom"
+ -DDYN_OPENAL=OFF
+ -DNO_GTK="$(usex !gtk)"
+ -DNO_OPENAL=OFF
+ -DHAVE_VULKAN="$(usex vulkan)"
+ -DHAVE_GLES2="$(usex gles2)"
+ -DNO_OPENMP="$(usex !openmp)"
+ -DZDOOM_ENABLE_SWR="$(usex swr)"
+ -DBUILD_NONFREE="$(usex non-free)"
+ )
+
+ use debug || append-cppflags -DNDEBUG
+ use telemetry || append-cppflags -DNO_SEND_STATS
+
+ cmake_src_configure
+}
+
+src_install() {
+ newicon src/posix/zdoom.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use non-free ; then
+ ewarn
+ ewarn "GZDoom installed without non-free components."
+ ewarn "Note: The non-free game_support.pk3 file is needed to play"
+ ewarn " games natively supported by GZDoom."
+ ewarn "A list of games natively supported by GZDoom is available"
+ ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"
+ ewarn
+ fi
+}
diff --git a/games-fps/gzdoom/metadata.xml b/games-fps/gzdoom/metadata.xml
index 5bd8c339a086..79b8864223c7 100644
--- a/games-fps/gzdoom/metadata.xml
+++ b/games-fps/gzdoom/metadata.xml
@@ -16,6 +16,7 @@
<use>
<flag name="gles2">Enable GLES2 backend</flag>
<flag name="non-free">Enable non-free components</flag>
+ <flag name="swr">Enable software renderer</flag>
<flag name="vulkan">Enable Vulkan support</flag>
</use>
<upstream>