summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-11-18 19:33:22 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-09 16:18:42 +0100
commit53f65ab74e4cf0b91f9c9aebab916231db1dc5fd (patch)
treeeaa8c3cc7796f39b24f9f77f10a47141bfd737e2 /games-puzzle
parentgames-board/domination: drop unneeded dependencies, update EAPI 7 -> 8 (diff)
downloadgentoo-53f65ab74e4cf0b91f9c9aebab916231db1dc5fd.tar.gz
gentoo-53f65ab74e4cf0b91f9c9aebab916231db1dc5fd.tar.bz2
gentoo-53f65ab74e4cf0b91f9c9aebab916231db1dc5fd.zip
games-puzzle/pauker: patch failing javadoc
Closes: https://bugs.gentoo.org/829503 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pauker/files/pauker-1.8-javadoc.patch34
-rw-r--r--games-puzzle/pauker/pauker-1.8-r3.ebuild1
2 files changed, 35 insertions, 0 deletions
diff --git a/games-puzzle/pauker/files/pauker-1.8-javadoc.patch b/games-puzzle/pauker/files/pauker-1.8-javadoc.patch
new file mode 100644
index 000000000000..ab87fe73c723
--- /dev/null
+++ b/games-puzzle/pauker/files/pauker-1.8-javadoc.patch
@@ -0,0 +1,34 @@
+#829503
+--- a/src/pauker/program/gui/swing/LineLabeler.java
++++ b/src/pauker/program/gui/swing/LineLabeler.java
+@@ -25,7 +25,7 @@ import javax.swing.text.JTextComponent;
+
+ /**
+ * A panel for labelling the Pauker import dialog
+- * @author Ronny Standtke <Ronny.Standtke@gmx.net>
++ * @author Ronny Standtke
+ */
+ public class LineLabeler extends JPanel implements DocumentListener {
+
+--- a/src/pauker/program/Card.java
++++ b/src/pauker/program/Card.java
+@@ -118,7 +118,7 @@ public class Card {
+ /**
+ * sets if the card is learned or not
+ * @param learned if true the cards state is set to learned and the current date is used as
+- * </CODE>learnedDate</CODE>
++ * <CODE>learnedDate</CODE>
+ */
+ public void setLearned(boolean learned) {
+ frontSide.setLearned(learned);
+LongTermBatch.java:101: error: @param name not found
+--- a/src/pauker/program/LongTermBatch.java
++++ b/src/pauker/program/LongTermBatch.java
+@@ -98,7 +98,6 @@ public class LongTermBatch extends Batch {
+ }
+
+ /** gets an expired card
+- * @param i the index of the expired card
+ * @return the expired card
+ */
+ public Card getOldestExpiredCard() {
diff --git a/games-puzzle/pauker/pauker-1.8-r3.ebuild b/games-puzzle/pauker/pauker-1.8-r3.ebuild
index 6fb8a63cf540..cadeed423644 100644
--- a/games-puzzle/pauker/pauker-1.8-r3.ebuild
+++ b/games-puzzle/pauker/pauker-1.8-r3.ebuild
@@ -31,6 +31,7 @@ BDEPEND="app-arch/unzip"
PATCHES=(
"${FILESDIR}/${PN}_bundledjars.patch"
"${FILESDIR}/pauker-1.8-r3-project.properties.patch"
+ "${FILESDIR}/pauker-1.8-javadoc.patch"
)
src_prepare() {